Can sombody explain how to set up FastDL on Garry's Mod

i need help on how to set it up to download my maps and custom stuff i have a webhost and all but i need help on how to do it please help me out

On your webhost, you need a folder named “garrysmod”, and inside that folder is where you keep folders such as “materials”, “models”, “sound”, etc. Have your sv_downloadurl point to that garrysmod folder. So in server.cfg, add a line like:


sv_downloadurl "http://www.yourdomain.com/garrysmod"

so that when you type that url into your web browser, you come to the barebones file browser showing you the materials, models, and sound folders.

Note that if you are adding a model or texture from an addon, you don’t put it in /addons, you put it directly in models on the fastdl server. Fastdl doesn’t read /addons

Always when i set it up, the content never downloads to my cliënt.
Does someone know how to fox this?

Are you sure you have resource.AddFile in your gamemode pointing to the correct filenames?

Yes, the file name is “recourses.lua” and it’s located in lua\autorun

download_debug 1
developer 4

connect to the server, paste the output of the console here in


[noparse]


[/noparse]

tags

Did you run

download_debug 1
developer 4

Yes, but now it somehow did download the models, i saw it downloading alot of .mdl files.
But now i when i spawn it, i get errors and this is what comes up in the console.

those all look fine, what models/materials aren’t downloading?

This:

The only one that i can see not downloading are alot of bs2 files.
They just fail downloading. But other then that, i can not find any files that are not downloading.

that just means that the compressed version of the file wasn’t found so it looked for the non-compressed version to download.

that isn’t necessarily bad but it is nice to compress your files so players can join quicker

Allright it works now :smiley:
Anyway i got one more question for you, i have bzipped the map with bzip, but where do i place the rar file that i got?

Players can only download BZ2 compressed files, not rar/zip/7z/any other formatS

[editline]23rd December 2012[/editline]

if you want to BZ2 compress files I recommend the 7-Zip program, just make sure to change the format to BZ2 compression before creating the archive

i have that but it doesnt work it only downloads my maps not materials and models?

Mister Banana Lord, I also haz a problem with my fastDL, I have it set up… it works… except the models, _undefined said something about garry not fixing it yet like if your models and shit are in the folder and not in the root, they won’t download.

I use _undefined’s pointshop, I added a Russian Hat in the pointshop, people can download it but they see purple/black checkered texteru (pink as some say)

I did contact _undefined he is just too busy.

I can’t testify to Undefined’s pointshop but I have a gamemode and 2 addons recursively adding files in their folders (aka they aren’t merged with the root directory structure) and it works fine. My only guess is that the casing doesn’t match 100% between the webserver and the gameserver (most webservers are Linux, and Linux is case-sensitive).

ie.

server:
path: models/player/cop/policeman.mdl
resource.AddFile( “Models/Player/Cop/PoliceMan.Mdl” );

webserver:
path: models/player/cop/policeman.mdl.bz2
that is not the same as Models/Player/Cop/PoliceMan.Mdl

oh god, I see 2 problems I might have had… model is not bz2’d + I changed the actual models original path to an organized folder… I thought it should have no problems when I checked the models/model.mdl file I realised it had a connection with the texture of the materials/models/model.vmt file.

You, KIND of helped me but then I helped myself, who cares here’s a Wrench in your banana face!

I’m still having my issue but it worked fine before. It started happening after activating cloudflare than things started not downloading and giving the “HTTP error downloading” except some of them are there and some were not. The files that were there were not there “according to console” were there and the ones that were not there “were not there”. I don’t see why it won’t work and I even put it in resources.lua and lua/autorun/server but it won’t download to my clients.


(User was banned for this post ("Bumping a 2-year old thread" - Megafan))