Can Someone help me

Sorry if this is in the wrong place, if it is tell me the right place and ill put it there.

I keep geeting this everytime i try to uplaod to the steam workshop using GMPU, in the Queue in the status area it says Error! Exit Status(1). can you please help me?

Image for icon selected. Loading and Checking Image…
Image is 512x512. Loading preview…
Preview Loaded.
Executing queue.
Creating addon from C:\Users\Pleb_King_Plex.mogler-PC\Desktop\soundsweps\Eating and drinking sound swerp…
Creating temporary addon.json.
Creating temporary gma.
Garry’s Mod Addon Creator 1.1
Looking in folder “C:/Users/Pleb_King_Plex.mogler-PC/Desktop/soundsweps/Eating and drinking sound swerp/”
lua/weapons/sswep_eating_sound.lua
materials/entities/sswep_eating_sound.png
sound/weapons/marchingsongs/burp.mp3
sound/weapons/marchingsongs/eating.mp3
sound/weapons/marchingsongs/gulp.mp3
Successfully saved to “temp.gma” [185.7 KB]
Garry’s Workshop Publisher 1.1
[Compiled Nov 11 2016 - 19:23:41]
Storage Quota: 1.0 GB total, 1023.8 MB free
Opening temp.gma
Compressing… [185.7 KB] => [133.0 KB]
Deleting addon_uploads/1485036445_93995141.gma (133.0 KB)…
Sending Addon to Steam…
Couldn’t load icon - is it a jpeg?
Deleting temporary gma…
Temporary gma deleted.
Deleting temporary addon.json…
Temporary addon.json deleted.
[WARNING] Creation Failed!
Finished running queue.
Refreshing addon list.
Retreving list of Addons.
ID: 819572944 Name: “Military Candence Sound Swep”
ID: 819643027 Name: “Sound Pack Part 1”
Retrieval Finished!
Finished refreshing addon list.

Error states right there.

I changed the image and the image is a Jpeg and is 512x512, I have tried 4 other photos and still get the same thing.

[editline]21st January 2017[/editline]

nvm fixed it idk but when i changed the jpg for the 10th time it fixed

IIRC the file size of the icon could have also been causing an issue.