Cannot connect with friend. (Tried several steps)

Edit: Fixed.

Original Post.
A friend of mine just bought this game but we are unable to join in an empty server between us.

  1. Nether my friend nor I can create a MP server viewable in the server-list. (It is not viewable from the list).
  2. Nether my friend nor I can join each others created server via steam (auto join or invite, “server is not responding”)
  3. Under the “friends” tab when he (or I) host a server, it says they “are not currently playing a game.”
  4. Nether my friend nor I can find each other in a LAN game if we run with Hamachi (this was our final option, “server is not responding”). Nether his or my server appears.

We can join public servers, but we do not want to deal with public join-in-progressee’s or server settings undesirable to us. Any tips appreciated.

I’ll try my best to give some advice.

1.Are your ports forwarded?
2.Again, same as 1.
3.That could be because they are in a single player game(playing by themselves)
4.I don’t use Hamachi, so I dunno, probably have to do with forwarding ports maybe?

I recommend installing something called “srcds” you can search up a tutorial on Youtube about it and how to get it up and running. Or you can simply forward your ports and manually create a multiplayer game.(through the Gmod option when picking a map)

Could you refer me to a link with instructions on how to port forward (for gmod)?

Make sure to know your model/manufacturer(you can look on your router). Click on which one it is, then click on Half-Life 2 Steam Server(since it’s the same), and the guide will tell you from there on how to forward your port.
EDIT:Whoops, the site is http://portforward.com/ haha.
EDIT 2:
Or, instead of clicking on Half-Life 2 Steam Server, you can go here http://wiki.garrysmod.com/?title=Windows_Dedicated_Server_Setup and scroll down to “Port Forwarding” and try to open all of those ports. (I would, just to be safe) but with the same directions that portfoward.com gives you.

Got it to work. Thanks Howard.