Cannot get on garrysmod.org

when i click the link, or just type in the address bar, it will load for like five minutes then say “Oops! Internet Explorer cannot display the webpage”. if i go onto it on my iPhone (which ruins the point, anyways) and it will still load forever but will show a webpage. I’ve tested this on several computers (3 PC’s and 1 mac) and all the same result, save the fact that the safari failure doesnt say “Oops!” I can use the cached page, but if i click a link it wont work. I anyone can help thank you.

Me too! :suicide:

Must be down, doesn’t work for me ether.

On, and off, on and off. MAKE YOUR F*KING MIND UP!

k, i got on earlier today, but now it doesnt work. also when i did downloading was super-slow, on all three mirrors, on a small thing

It’s up and it works perfectly fine. :geno:

Is there going to be a new post every time the site hiccups?

hiccups? i think you have what im saying backwards. it WORKED for a few minutes, and hasnt before or since.

Heres a thread i made about how to fix it. Just check it out C:
http://www.facepunch.com/showthread.php?t=917629