Cannot Join Server

Hello,

I am having an issue joining a specific server. Every time I go to join it, it says it is connecting and then it flashes back to the home menu of Rust. Has anybody had this problem and been able to overcome it?

Thank you.

Edit: I have verified the game’s cache integrity, I have uninstalled then re-installed the game, and I have tried both dev mode and regular.

I am experiencing the same issue with all servers not just one

because rust is busy with steam

I’ve been having this issue since before the steam launch. So, that would be incorrect. Also, I fail to see how a steam launch would make the game unplayable.

I do appreciate the input, though.

That issue isn’t on your end, it’s an issue with the server itself. Probably needs a reboot, i had 2 guys having the same problem joining my server. I could join it fine without issues, after i rebooted it the others could all join.

When you click on a server to connect to hit, quickly hit F1 and see what the error is.

net.connect xx.xx.xx.xx:port
connecting to xx.xx.xx.xx:port
Connecting to server
ConnectionFailed

That’s trying to join a specific server correct? It’s not all of them?

If so, find out who owns/admins it and ask them to reboot.

I have tried over 10 servers now. it’s the same problem, perhaps because I just downloaded rust…
well… gonna wait till tommorw

Do you get the same error trying to connect to the ‘Official’ servers?

Yes