Cannot open GMod!

Whenever i open GMod from steam, it starts to load until it gets to “initializing serverside”. Then, it minimizes the window followed by it saying “hl2.exe is not responding” then it closes. It just started happening yesterday (23rd) and i tried a bunch of things and none have worked. Some help, please?

Oh, and merry christmas eve.

Odd. I Get this problem. Do this Delete local content and reinstall.

Alright, ill see if it works. Thanks.

[editline]06:46PM[/editline]

It still does the same thing, it doesnt work. Any other help?

Goto steam Support it might help.

I recall having a problem similar to this months ago. I started it up, but before Garry’s Mod could even open, it gave me that hl2.exe error thing. What I did was backup all my favorite addons, maps, materials, etc. and then completely deleting my garrysmod folder (C:\program files\steam\steamapps(name)\garrysmod.)

After that, I reinstalled Garry’s mod, tested it (it worked,) and then moved my stuff back.

Try it and report back to me if you can.

-X6ZioN6X