Cannot play custom sounds?

I’m trying to play a custom sound on my server. The sound is located D:\Servers\Gmod\garrysmod\music\quake so I put ] ulx playsound music/quake/monsterkill.wav and I get the error ‘That sound doesn’t exist on the server!’.

I’ve also tried playmusic/quake/monsterkill.wav and received the error ‘Failed to load sound “music\quake\monsterkill.wav”, file probably missing from disk/repository’ so what could I be doing wrong? Also, paths like these npc/metropolice/vo/moveit.wav work fine.

Any help would be much appreciated.

Try ulx playsound sound/music/quake/monsterkill.wav

Am I suppose to have a sound folder? Because I’ve never had one before.

Yes, all sounds should be in garrysmod/sound. From there, subfolders can be made such as music and such.

Still, no progress. :\

Then you don’t have the sound on your client.

How do I play it server wide? or if I did FastDL would that help?

You have to send the sound via FastDL.

Still nothing. This doesn’t make any sense! I created a sound folder inside my folder that is in sv_downloadurl and maps work in the maps folder, but when I put my quake folder inside the sound folder still nothing! x________________________________________x

Post your FastDL link.

Your sound needs to have a Sample Rate of 44100 Hz for the Source Engine to be able to play it.
Although, you use the quake sounds so they should be fully compatible.

Anyway, post your FastDL link as code_gs said and triple check that the files structure is the same for your resource.AddFile script.

Sorry guys, here it is.

“triple check that the files structure is the same for your resource.AddFile script.”
What do you mean?

Dropbox doesn’t work for FastDL. Get another host.

Do you know any free ones?

There is no free hosting that allows FastDL mirrors (Hosting of game content). You have to buy one.

Then how would I go about hosting my own?

Forward port 80, install a web-server like apache. I suggest you to get the entire WAMP Server software (Windows, Apache, MySQL and PHP in a package) if you plan on hosting a website later on. Either way, you need Apache.
Then you put the sounds in a web-server directory, put the server online and then change your server.cfg params to this:

sv_downloadurl ""
sv_allowdownload 0
sv_allowupload 0 // Security measure, make sure it's disabled.

Alright. Does it have to be named “fastdl”? I just put it inside htdocs/garrysmod/sound

For the sv_downloadurl I put sv_downloadurl “http://my.public.ip.address/garrysmod

Here’s a wav file I converted to 44100hz if you want to check it out or test it.

I also had my friend see if he had access to play http://my.public.ip.address/garrysmod/dominating.wav and he did. So the web server is working fine.

Again, thanks for the help.

Then everything should be working perfectly fine!

Could you try and see if you can make it work in gmod?

[editline]25th January 2014[/editline]

Aha! For some reason, they’re not downloading via my websever. I thought sv_download was suppose to be set to 1?