Cannot start Garry's Mod server with a custom workshop list

OS: CentOS 7 x64

Same issue as this old thread: http://forum.facepunch.com/showthread.php?t=1335192

I can launch fine without workshop, but when i set up an collection, the server crashes

Log:


~Console initialized.
Couldn't load shader dll: game_shader_generic_garrysmod_srv.so
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load: /.steam/sdk32/libsteam.so
with error: /.steam/sdk32/libsteam.so: cannot open shared object file: No such file or directory
Logging into anonymous gameserver account.
Fetching Workshop Addons..
Calling GetCollectionDetails
terminate called after throwing an instance of 'std::logic_error'
what(): basic_string::_S_construct null not valid
./srcds_run: line 372: 10008 Aborted $HL_CMD
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Thu Sep 24 05:32:01 BRT 2015: Server restart in 10 seconds

Tried different collections, apikeys and a reboot but no lucky

Does anyone have any idea about what causes this issue?

Update, same issue on Debian 7/8 x64 as well

Github issue:https://github.com/Facepunch/garrysmod-issues/issues/2251

4000 typically is the ID of the collection link page, not the collection itself.

Try going into the collection itself, then right click the blank area along the side of the page and choose “copy URL” the actual steam ID should be the last 7 or 8 numbers in the URL.

I guess you din’t read it properly, Setting breakpad minidump AppID = 4000 has nothing to do with the Workshop

what is your collection id and give us your start command (without your authkey)

[editline]5th October 2015[/editline]

also incase you didnt know everyone has their own authkey, if you used one you found online that wont work

[editline]5th October 2015[/editline]

I’ve tried with several collection IDs, my ID is 163440268

And i’m using my own Api key

Startup:

./srcds_run -console -game garrysmod +ip myip -port myport +host_workshop_collection myid -authkey mykey +gamemode darkrp +map mymap +maxplayers 22

-snip-
Misunderstood

drop a -verify_all in your start command, could be an issue with install