Cannot use thruster tool gun

For some reason I can’t spawn thrusters at all. It doesn’t work in SP or MP, I’ve tried reinstalling and also deleted my entire gmod folder for a complete install. Neither has worked. I have no idea what the issue is.

Try getting rid of all of your addons. If this doesent work then reinstall all source games or even steam. Hope this helps

Actually no.
If it’s just the thrusters:
Delete/move your addons folder (GarrysMod/garrysmod/addons) and see if it still happens. If it does, follow these steps:

1 - Verify game cache (And if it actually showed the message of “x files restored” - or something among those lines, Proceed to steps 2-4)
2 - Open up gmod and see if it works
3 - Wether or not it works now, close gmod, and verify game cahce again
4 - Tell us if on 3, it showed the same message as in 1.
5 - If 1 didn’t do anything: Re-install gmod (Proceed to steps 2-4)

Needless to say if you get any console errors while playing (Yellow text when you press the ~ button - Below Esc), paste them here