Can't access the console.

The problem being that there’s no “~” key on my keyboard configuration unless I hold CTR + ALT down which, of course, doesn’t work cause I crouch and walk. My keyboard configuration is from a different country and, apparently, I can’t change it. There any way to change the key used to open the console like in other games or anything that could help me with that?

In any case it isn’t possible, is it possible to use third person view on Gmod?

Try pressing `

If that fails, open garrysmod/garrysmod/cfg/config.cfg and replace ‘bind ~ toggleconsole’ with bind ‘b’ 'toggleconsole

Yeah, you just need to bind the console to a different key and you should be set.

How do I open .cfg files? Or, what kind of program do I need to open it?

Wait.
Isn’t there a Console bind in the keyboard settings in Gmod?

If not, you could do binds by console, but that isn’t working :stuck_out_tongue:

As for CFG files, Just right click > Open With > Notepad / Wordpad
But they should open with, IIRC Wordpad automatically.

Did that, changed the “" with "b" or whatever key, but still doesn't work. When I do that while using Gmod it doesn't work, if I exit and enter Gmod again it resets back to "”.

I know this is a basic question, but is it enabled in settings.
In gmod, on the main menu go to
Settings > Keyboard > Advanced Settings
And tick the ‘Developer Console’ part, next to the Fast weapon switching option.

Try this if you dont want to mess with that stuff.
On the game properties(Right click, properties) click on “Set launching options”. Then, write “-console” Without commas. When it finishes loading, it should appear

Then type in it


bind b toggleconsole

Press b, then it should work

Its Bind “B” “toggleconsole” ingame isn’t it?

Knew that already since I’ve used console on TF2 before.

Also, yes, I’ve done the
bind “b” “toggleconsole”
thing plenty of times. Still doesn’t work, no matter what key do I put there.

Also, right clicked on properties and the launch settings doesn’t seem to be anywhere. There anywhere in specific I gotta open it’s properties at?

Its in steam.

my games > Right Click garry’s mod > Properties > Set launch options.
then just add -Console

Open notepad, Type in bind b “toggleconsole” then save into garrysmod/cfg as autoexec.cfg

THANKS A LOT

It worked now. :smiley:

No problem, always happy to help.

I was gonna say this :stuck_out_tongue: I use this on every game that has a console