Can't click in certain gamemodes.

Hey all, first time actually asking for help in the section. For some reason, in some gamemodes, I can’t click. This has happened so far in Flood, and a custom gamemode I’ve been programming. This problem does not happen in Sandbox (which is what is confusing me, it’s not consistent). I’ve tried using a plugged in mouse, nothing changes. I’ve disabled all my addons, reinstalled gmod, disabled steam cloud, reinstalled again, each attempt showing no fruit. This problem has only recently started to occur as well, Last week I didn’t have any this problem. At first I thought it was maybe the work I was doing creating a new console (maybe the DTextEntry was hogging the focus), but the problem persisted after uninstalling it, and after a fresh install of gmod.

Thanks for reading.

[editline]22nd April 2015[/editline]

Update: It’s only when I’m holding down a key (I’m W8.1, and I have disabled the toughpad wait time, so that’s not the issue)

I’m going to bump this slightly.

Does this happen after alt tabbing, running full screen or windowed?

I’m running the game windowed, and I don’t alt-tab to switch between windows, so no.

Any help?

Bump.

When you say you can’t click, do you mean ATTACK1 doesn’t work or do you mean that your mouse input isn’t going through to a DButton or some other UI element?

UI elements.

You could try printing out vgui.GetHoveredPanel () in a timer when the console isn’t open to see if there’s some big alpha 0’d panel covering everything.

nope, prints lots of nothing.

[editline]28th April 2015[/editline]

I got a list of panels created if that helps:



] lua_run_cl for k,v in pairs( vgui.GetWorldPanel():GetChildren() ) do print(v) end
Panel: [name:Panel][class:Panel][0,0,64,24]
Panel: [name:Panel][class:Panel][0,0,64,24]
Panel: [name:Panel][class:Panel][0,0,64,24]
Panel: [name:EditablePanel][class:LuaEditablePanel][20,438,520,102]
Panel: [name:EditablePanel][class:LuaEditablePanel][10,438,800,600]
Panel: [name:GModMouseInput][class:CGMODMouseInput][-500,-500,128,66]
Panel: [name:EditablePanel][class:LuaEditablePanel][0,60,616,750]


Update: It’s in all gamemodes, but I only noticed it in some because of the nature of the problem: When I click and move my mouse (eg, DScrollBar, Drag and Drop, etc), it doesn’t send my mouse movements.

[editline]29th April 2015[/editline]

solved, I forgot that I recently installed matt’s 3d2dvgui lib. Evil matt.