Can't connect to any servers

When I launch the game and go into the server browser, there is nothing there. Tried refreshing, restarting gmod, restarting steam, verifying the cache, doing the update. It still does nothing.

When I try to force connect with legacy or in the console using the IP, it won’t connect to the server. It just gives me a timed out.

A friend of mine recently purchased a game server and I am helping him set it up and it is vital that I get on to the game… How can I fix this?

  1. Check your filter settings, you might be filtering out all of the games.
  2. Check your firewall to make sure the connection isn’t blocked
  3. Try to connect to a few other gameservers, not just one.

It’s not filtering them out

The firewall isn’t blocking it, I was playing at 2:30 this morning. It just stopped working after the update was installed.

I have tried many different servers and many gamemodes.

Could this be a steam thing, not a gmod thing? this happened to me with tf2 a few days ago as well.

have you tried connecting to servers by ip?

Yes, he did.