Can't connect to my own dedicated server, while others can?

One day ago everything worked fine, me and my friends played on my dedicated server. But something happened.
Now i cant connect to my server via 192.168.1.156 ip nor my public ip (couldn’t before with public, i assume it’s normal).
My friend is playing in server right now and i see the server in server list, but cant connect.
my ports:

Check all of your firewalls and add exceptions or shut them down.

Firewall IS shut down.

If it’s on your computer, or on your network, try connecting with the local IP.
Either 127.0.0.1 or 192.168.1.156

tried both, no response.
before i could only connect through 192.168.1.156

[editline]10th June 2014[/editline]

Now i noticed one problem: when my server is on i cant connect to any other server.
I tested it by playing on random server, then turning on my server, and i get disconnected from the server

Don’t run your server through port 27015.

Probably because you’re forwarding your client port (udp 27005) to your server and your router is routing internal traffic externally… or something weird.

Didn’t work. Even if i run server in lan same happends.

[editline]10th June 2014[/editline]

Bump. It is still a mistery to me why it worked perfectly before, i didn’t change any ports

[editline]10th June 2014[/editline]

FIXED! validated server files from steamcmd and it works! thx for the effort