Can't decompile TF2 Player models AT ALL and I'm in distress

So I want to decompile the Spy player model. Open up XVI32, change “IDST0” to “IDST,” and decompile. Decompiler crashes. Tried with “IDST.”, “IDST/” and even with “IDST0” itself.

Nothing.

No checkbox is checked.

Decompiler is in the sourcesdk/bin/ep1/bin folder, it’s version 0.5 (latest), because it doesn’t run at all from the sourcesdk/bin folder.

Yes, I googled. Everyone said “IDST0” to “IDST,”.

It might just be a typo in your post, but it looks like you used IDST**.** instead of IDST**,**

and try running ot from the orangebox/bin folder instead?

-Sound Scissors Make-

I used comma, a stop and a slash. None worked

“The procedure entry point Q_AppendSlash could not be located in the dynamic link library vstdlib.dll.”

Also, Lord Ned sent me the files, but I still wanna fix this incase I want to decompile something else.

IDST0 to IDSTO?

I can decompile TF2 Player models just fine, if need be, I could give you whatever one you want.

Put it in sourcesdk/bin/ep1/bin, not orangebox

Read the OP better

[editline]03:36AM[/editline]

Didn’t work sadly. Thanks anyway!

Dont do that IDST thingy, but use this decomp instead: http://www.filefront.com/14033171/mdldecompiler_hacked.zip/
It works like a charm no matter what tf2 stuff I decompile

Won’t do justice either.

After Changing IDST0 to IDST, (in the model) it worked for me, but the animations are all fucked up D:

Okay, this is weird.

With the hacked decompiler, I can only decompile the Pyro. Nothing else.

And that’s probably only because the Pyro doesn’t have any facial expressions and such.

Aww man TF2 playermodels and the decompilers acts like a bitch!

Yeah, the Pyro wears a ask so he doesn’t have any facial expressions. Also the TF2 player models have different face designs than the HL2 ones, but I don’t know if that’s what’s wrong.

I have the same problem with the L4D models, I can start the decompiling if I change them from IDST1 to IDST, but it crashes and only gives me a .vta file (the expressions file).

Yeah, L4D models only work with an older decompiler.

Do they, which decompiler do you need, I’ve tried StudioCompiler and MdlDecompiler and neither of those worked.

MDLDecompiler 0.4 I think. Also, try with AND without IDST,

I’ve had the exact same problem.

I’ve used the hacked decompiler, edited my gameinfo.txt file to ignore the ToolsAppID issue, etc.
I can get the decompiler to tell me it’s loaded a model, as long as I manually type in the actual path to the .mdl file, (trying to use the browse feature crashes the decompiler).
When I actually hit “Extract”, the decompiler simply crashes.

I had previously extracted everything from the TF2 set about 6 months ago, but just recently realized that the .VTA for the engineer didn’t successfully get extracted. (The .vta’s for all the other characters came out just fine).

I don’t suppose anybody has a mdldecompiler_expressions.vta for the engineer out there that they’d be willing to send me do they???

Well, so why don’t you try MDLDecompiler 0.4 ? As you said, only Pyro could be decompiled because he has no facial expressions, and MDLD 0.4 worked on L4D models (L4D models have the problem that can’t be decompiled with facial animations).

Really? Thats the only part I can get when decompiling them O.o