Can't figure out how to run two r_ commands on map start

I’ve been out of the mapping game for a good year now so I’m a bit rusty, I’m trying to run two commands when my map starts. r_rainwidth 5 and r_rainspeed 300.

I’ve got a logic_auto connected to a point_clientcommand but it doesn’t seem to be working, here are the inputs I have:

http://dl.dropbox.com/u/3794151/Screenshots/ZScreen/Object_Properties_logic_auto-2010-10-16_19.49.56.png

This is going to be a TTT map, if that makes any difference. Any help would be appreciated.

Edit: Sorry, I guess I should have posted this in the mapping questions thread.

Do these need cheats? Try to type them into console right after opening the game and it’ll probably tell you.

If you do, add a new command at the start “sv_cheats 1”, then give the rainwidth/speed a delay of .5 or so, then turn cheats back off.

point_clientcommand and point_servercommand is disabled in Garrysmod. You would need a script or something.

No they don’t need cheats and how would I go about doing the script then?

Ask the lua section.

You could use a simple lua_run entity that just sets the values. Wouldn’t be very hard at all.

[editline]18th October 2010[/editline]

Unless Garry blocked that.

What would the LUA code be for the LUA_run?


Runconsolecommand("command_here value")

Whenever I put that in it ends up corrupting my map with the following error (or things akin to it)

http://dl.dropbox.com/u/3794151/Screenshots/ZScreen/Error_loading_file-2010-10-18_17.16.17.png

Double quotes can’t be used in VMF key or value strings since they’re already used as data delimiters. Try using single quotes instead.

Well that solved that issue but now I get



[RunString:1] attempt to call global 'Runconsolecommand' (a nil value)
[RunString:1] attempt to call global 'Runconsolecommand' (a nil value)


In the console in Gmod

[lua]Runconsolecommand (‘r_rainwidth 5’)[/lua]

Is what I have in the entity. I tried doing Lua_run Runconsolecommand (“r_rainwidth 5”) in-game and got the same error so it’s not the lack of double quotes that’s breaking it.


RunConsoleCommand( 'r_rainwidth' , '5' ) ; RunConsoleCommand( 'r_rainspeed' , '300' )

It works! You sexy beast, Terrenteller. Thanks for the help everyone.