can't figure out what I'm doing wrong remaking a .gma

I intend to take the addon found on the workshop here: http://steamcommunity.com/sharedfiles/filedetails/?id=230554919 and swap the music out for my own.
The method I tried was to first

  • download the addon
  • extract the addon from the .gma
  • swap out the original 9 tracks for my 9 tracks, all the same length as the old ones
  • use gmad to remake the .gma
  • upload to workshop and add it back to my workshopDL

BUT, it seems that when I try to remake the .gma using the gmad that comes with Garry’s Mod it tells me:

I put in:
gmad.exe create -folder "
J:\gmod\build" -out “J:\gmod\complete\music.gma”

It tells me:
Garry’s Addon Creator 1.0
Missing -out (the filename of the target gma)

It doesn’t seem like I’m doing the -out part wrong, but obviously something is stopping me from making the .gma.

Sorry if this is a dumb question, I’ve looked around and the best help I could find was in the gmad thread and it just said “You need to download the latest version” if you had this issue. Since it comes with gmod now I don’t really know what to do, or if that advice is still relevant.

Why use workshop at all? Just use fastdl and upload the necessary files.

Does that path actually exist in your out?

yeah the path exists, it’s an empty folder.
I’ve had issues getting fastdl to work at all. If you feel like spoonfeeding me instructions for that I would be happy to do it. heuhueehuehuuehue

You end your -folder parameter with a backslash, this means that you escape the last double quote. Use forward slashes and it’ll work. Because the last double quote for -folder isn’t captured, it thinks that the path you are trying to use as folder is


J:\gmod\build\" -out 

[lua]test = "Just testing " forward slashes --comment[/lua]
[lua]test = "Just testing " forward slashes --comment[/lua]

this worked, thanks.

Now when I try to actually make the .gma it gives me this:

J:\Programs\Games\Steam\SteamApps\common\GarrysMod\bin>gmad.exe create -folder "
J:/gmod/build/" -out “J:/gmod/complete/music.gma”
Garry’s Addon Creator 1.0
Looking in folder “J:/gmod/build/”
addon.txt
[Not allowed by whitelist]
lua/autorun/client/cl_end_round_music.lua
lua/autorun/server/sv_end_round_music.lua
sound/round/sound1.mp3
sound/round/sound2.mp3
sound/round/sound3.mp3
sound/round/sound4.mp3
sound/round/sound5.mp3
sound/round/sound6.mp3
sound/round/sound7.mp3
sound/round/sound8.mp3
sound/round/sound9.mp3
File list verification failed

What defines the whitelist? I made absolutely no changes to the lua files, so I don’t know if that guarantees they’re functional, or guarantees they are broken. All I did was replace the soundx.mp3 files.

i believe you need to remove addon.txt

worked, probably should have tried that earlier. thanks for the help all, marking as solved.