Cant' get gamemode to change to DarkRP

I’ve literally tried every option i’ve searched and found.
Still can’t get gamemode to change.

This is the DarkRP folder in my garrysmod/gamemodes folder.

http://pixldrop.com/view/jeCt2h.png

Correctly installed using the correct SVN link.
I’ve tried adding
sv_defaultgamemode “darkrp”
sv_defaultgamemode darkrp
sv_defaultgamemode “DarkRP”
sv_gamemode “DarkRP”
sv_gamemode “darkrp”
sv_gamemode darkrp

I’ve tried putting them in both my server.cfg and autoexec.cfg as well, but the game mode continues to stay as - Sandbox
This is on a server that i paid for from a hosting company.
Tried asking them, but clearly there not too intelligent and give me answers that i’ve already done and just told them i tried.

If anyone could provide any actual help that would fix my issue would be great.

Try rename the DarkRP folder and just call it darkrp instead and then edit the launcher and put in this “+gamemode darkrp” no sv_ infront and without the “”

tried that as well MhhToniix, literally right before you stated it.
continues to stay as Sandbox.

It’s rather annoying.

-snip-

Server.cfg: gamemode “darkrp”
Startup line: +gamemode darkrp

Then it will work unless you messed something up.

Have to get my server hosting to add the startup line as we can’t add custom ones ourselves.
i’ll get back to you guys and let you know how it goes when they finally do

I have the exact same problem, just with a dedicated server.

sv_defaultgamemode was renamed to just gamemode with the update to GM12. Having


gamemode "DarkRP"

in the server.cfg file should work.

This in server.cfg will work.
[lua] gamemode darkrp
[/lua]

Thanks guys, i got it to work.
Had to get my hosting provider to add ‘+gamemode darkrp’ to my command line manager as it doesn’t allow us to manually.