Can't get Garry's mod working

About 5 hours ago I played it just fine, but now I don’t know what this means but this is what it tells me
when I try to update it.
(An error occurred while updating Garry’s mod(disk write error)
This happened since I downloaded Windows 10 but I’m not quite sure if it was because of it
Anyways, I have tried some stuff but I can’t seem to get it working.

Help is very appreciated :smiley:

Hello, Is your hard drive full?

I am getting this as well and my hard drive is not full.

There seems to be some sort of issue with Garry’s Mod updating.

I’m honestly not exactly sure on the status of the situation though.

It doesn’t even finish the update and I cannot find the .exe file.

Either your internet connection is faulty or the partition, on which Steam is located is nearly full or you don’t have write access to Steam client installation directory(assuming that Steam client runs under user privileges).

This sounds more like he has the false positive virus issue and his scanner is blocking the file each time it downloads.

Well, I didn’t had such issue with Avast! antivirus, so if you’re using antivirus, you may want to check the log of it - it may actually get the cause of this problem. McAfee AV can cause this AFAIK.

I have disabled my antivirus software, yet the problem continues.

[editline]17th December 2015[/editline]

Titanic4, how would you fix stuff in your suggestion?

Validate the cache of every game you have mounted to Gmod, then validate Gmods, and it should work fine.

My buddy had the same problem and did what he said and it worked fine for him. Should work fine for you.