Can't Get Into A Server *HELP!*

Hello, I bought Rust today, and installed it around 2 hours ago, I loaded the game up, and when the servers started Loading, I went to Official. I found a US server with around 20 slots still open, so I joined it. It said Loading the map 2013 or something, then all this stuff about trees growing. Then after that was done, it just sits on the Loading screen forever, saying iti s ‘‘Waiting for server’’. Any suggestions? I realize this is early Alpha, but would like to play :).

They broke the browser in the last patch. You can open the game and then hit f1 to open your console.The enter a server ip. You can join mine and check out the game if you would like. Hit f1 then type net.connect 23.239.109.114:28145

I will try that, would you mind adding me on Steam? Rowan12312345
Maybe you could help a noob learn the ropes ;).

[editline]23rd December 2013[/editline]

Well, when I put that in, it seemed to be working, then this red wall of spamville pops up, saying over and over again, RenderTexture.Create failed: format unsupported, then this white text, skipped rendering frame because gfx(something) device is in invalid state (device lost). any help lol.

[editline]23rd December 2013[/editline]

Anybody :P.

[editline]23rd December 2013[/editline]

Tried this a second time got the same result :/.