Can't get NPCs to play my scenes

Hey guys! The problem is that the NPCs only play the coreography, no sound and no flex animations. It seems I’m doing everything right, I make my scene in FP, I copy it in garrysmod\scenes, I copy the wav file in garrysmod\sound and it’s available to use in NPC Scene tool.

I see so many videos on YouTube where people use their scenes all the time. So clearly it works, only not for me. I have no idea what’s wrong and I’m so damn frustrated.

Things I’ve tried so far:

  • I copied the scene and audio file in their respective HL2 folders;
  • I made my scenes in FP HL2 and FP HL2 E1 and again copied the files in their respective folders;
  • I replaced the sound that came with a game scene with my own sound and it worked. The scene would play it’s own coreography and my sound. Evidently, I then renamed and replaced a game scene with my own scene, but that didn’t work.
  • I watched Star Trek the Motion Picture and Star Trek II The Wrath of Khan because I couldn’t work on my machinima. So, please help me or tomorrow I’m gonna have a Star Trek movie marathon. And I DON’T have popcorn!

Other than that, I use Windows 7. Thanks!

Off-Topic.
Your avatar is just so cute!
:love:

Try the Valve Wiki?
Apparently the sound has to precise to some preferences, can’t remember what.

Thanks! He’s my long lost tom, Puf.

The audio was recorded in 24bit, 48000kHz, stereo and then resampled to 16bit, 44100kHZ, mono to be used in FP. But as I said, the audio worked in one (useless) situation, so I got the settings right. The flex animations won’t work at all…

Odd…
By ‘Long lost’ he ran away?
It’s a shame to lose a kitty like that.
This is my cat,
[IMG_THUMB]http://filesmelt.com/dl/Photo0089.jpg[/IMG_THUMB]

Anyway, I have no idea why that won’t work, you got further than me, I couldn’t even figure out how to get the speech working! :saddowns:

They’re twins! Yeah, he ran away. There are plenty of tutorials out there if you’re willing to learn.

Anyway, I don’t even care if I hear the sound, I can always add it in post, I just want the lips to move and the flex animations to play.

Come on people, how much William Shatner do you think I can take?

:rolleyes: Catpeople…

/offtopic Wow, Cats!!!

I had this problem too.

I was pissed, maybe updates?

I don’t know.

Off topic:
Whats with all the fucking cat avatars! I see them everywhere, and they only serve to be cute. Is it just a fad?

@BananaFoam You HAD it? You mean you fixed it or it got fixed on it’s own?

It’s just a damn picture of my cat. It’s not suppose to serve as anything. Let’s just focus on the topic.

It does mean that you are obsessed with cats, like my avatar means that i am obsessed with beholders, or it does if you even know what a beholder is.
/offtopic

Just go with the star trek marathon, i bet it will be more interesting that trying to make this sort of thing work right.
As for the popcorn, get off you’r lazy butt and get some if they are really so important.

Don’t let your obsession, or age, cloud your judgement. If I weren’t interested in sorting this thing out, I wouldn’t ask for help. They don’t do jokes in your dungeon, do they? You know, like the Star Trek joke I made and you did not understand? Let’s try this, maybe you do get it: “We killed the dragon! We killed the Dragon! We … we’re never going to have girlfriends, are we?”.

Oh, and you mistakingly assume that knowing what a beholder was is of any importance. I mean, I’m sure it’s required knowledge to enter the basement, sorry, I meant the dungeon, but hey, that’s an esoteric place where only a special few are permitted.

Now, if anyone can help me, please go ahead and write, if not, please refrain from further comments.

Well, I acnt really help you, btu yeah, I have this problem too.

I thought it might of been updates, but I never got it to work.

Thoguh I did get the presets of the tool to work, but now I can barely get any working, which leads me to believe this is update related.

If you need answers, I suggest contacting the maker of this fine tool. I don’t know where to find him though.

Well, if I ever get it to work, I’ll let you know.

Ok, 7 months later I accidentally found out the cause of this. When I launch Gmod, the game_sounds_manifest file reverts to its initial version, deleting my audio entries, hence no audio in my scenes. Can I get Gmod to accept my sound scrips?