Cant get past loading/connecting

hi there,

just purchased off steam, downloaded and fired up no issues.

when i go to join a server, i simply double click on it, then it goes to the loading(connecting…) grey screen and sits there.

tried various servers and have the same issue.

Ive had a look around for a fix to this but cant seem to find anything.

closed and reopened many times etc too.

running windows 8 / 64bit, running directly from the steam client.

I’ve had the exact same problem, and STILL haven’t found a solution… sucks =/

well thats annoying. $20 each wasted, no reply from anyone else so it may not be resolved yet. hoping someone can actually help with this !!!

Try posting more information:

Full Computer Specs

  • CPU / GFX / RAM / OS
    What version are you running?
    Have you Verified your game Cache on Steam?
    Have You Reinstalled?
    Is your Internet Connection configured correctly?
  • Firewall? Router?

yes its been verified

no redownload has been done. considering its happening to others i dont think this is going to be a fix.

i5/geforce vid / 8gb/win8

im runnign whatever the latest was, it was only just downloaded.

yes my internet is configured correctly.

yes there is a router, but there has been no instructions on how/what to forward in terms of ports , if any.

Do that. Why haven’t you? It’s like a 1gb game.

This doesn’t mean much, you need specifics. What kind of car do you drive? A Ford. Not much info there.

Is your account an admin? Are you running 8.1?

There is a massive amount of information that can be used to troubleshoot. You’re crippling yourself by not including it.

hi, i am having same problem ,it loads fine and then get stuck on character loading.,here are my comp specs.

*Apple macbook pro retina display 2013 model.
*Processor 2.6 GHz Intel Core i5
Memory 8 GB 1600 MHz DDR3
Graphics Intel HD Graphics 4000 1024 MB
Serial Number C02K7AE3FFRP
Software OS X 10.9 (13A603)

internet detail

  • UPC ireland
    *download speed 30mb/sec
    *upload speed 12mb/sec
    *fiber optic wireless internet.

At least you can get to the loading stage…

And this is very annoying, as my base will most likely get raided…

deleted and re downloaded, still the same.

ok so looks like its only some servers that i have the issue with. To test, i just went into a server that wasnt the one I wanted to go into, and that one magically worked.

I wonder if its a server side / patching issue?

Just an update, seems to not matter what i connect to, its just so hit and miss. shame really.

I’m getting the same problem…

I’ve tried joining a myriad of servers, and almost every time it stays on that loading screen.
My graphics card temp goes through the roof for some reason.

Every now and again it works; but it feels like pot luck.

Yep, I’m having the exact same problem. It only started happening recently too (for me), albeit I am also using a different connection than I usually use.

yeah its pot luck for sure. 1 in 20 connections will randomly work.