Can't get up main menu by pressing ESC

Hey…

The title is my problem… Whenever I goes on a server, and tries to open the menu by pressing ESC nothing happends… Everything seems to work just fine, but that won’t work… It’s pretty annoying because if I want to change map or leave the server, I can’t because I can’t get into the console or menu… Only time when I can be at the menu, is when I start it, and havent got into a server yet… So if I want to quit, I have to press the X in the corner.

So far, I have tried this with no success:

To delete my GMod folder, and re-install it.

Any help would be greatly appreciated.

How odd.
What is your keyboard layout?

It is odd…

My keyboard layot looks like this, with numpad on the side: http://www.electronickeyboards.com/83POS64N.JPG

Also I can’t get up the menu on Counter-Strike: Source… Any ideas how to fix this?

Does it work in anything else…at all?
Tried key combos? Looking up similar problems with the keyboard?

Problem solved… I just had to change keyboard, because the ESC key was broken.

Stupid me…

Thanks for trying to help whosdr, greatly appreciated!