Can't Hear Music In "Rooftops 2016"

(This Error Was On Linux)

When I press “What Is Love” it gives me this error in console:

Failed to load sound “rooftops/what is love.mp3”, file probably missing from disk/repository
Create Stream Failled error 44

When I go on my other computer ( which is on windows) it works perfectly fine.

What do I do?

(I’ve also did a discussion on steam)

:snip:,

https://facepunch.com/fp/browser/linux.png

linux doesn’t normally support mp3 playback, just dual boot that shit and do your gaming on windows

The Linux versions of Garry’s Mod handle the case sensitivity of the file system in an incredibly dumb way: all filenames absolutely must be in all lowercase, or it will not be loaded by the engine.

(You might also be missing MP3 codecs, like the above post mentioned, but you can install MP3 support, no need to switch operating systems over it)

[editline]16th August 2016[/editline]

so, go into whichever addon this is and open the sound folder, and make sure both the “rooftops” folder and “what is love.mp3” are in all lowercase.

It doesn’t like blank spaces on paths either, at least on SRCDS.

Have you tried turning your volume up?

Have you tried not posting?

OT: Why are you gaming on linux? I can understand launching tf2 on linux back in the day for the linux item but just don’t actually play games on linux please.

works fine on my machine

I went into the sound folder and I couldn’t find the folder “rooftops” anywhere . . .

The one in garrysmod/addons/wherever_rooftops_is/sound or garrysmod/sound? They’re two different directories.

[editline]21st August 2016[/editline]

And when you do find it, double click it and make sure it actually works. If not, run this in a terminal (I’m assuming you’re on Ubuntu):


sudo apt install ubuntu-restricted-extras