Can't Join a Local Server if a Player is Already Connected

I have a Laptop and a Desktop running on the same local network. My local development server is running on my Desktop, with a maximum player count of 16. Both machines are running Steam under different accounts, with completely separate copies of Garry’s Mod. I’m not doing Family Sharing.

If I try to connect to my development server from either computer when there are neither computer is in the server already, I can connect fine and I’m in-game in 20 or so seconds. However, if I try to then connect with the other computer (happens no matter which joins first), it hangs at the “Authenticating with Steam…” step indefinitely. It doesn’t time out, it just sits there. I’ve tried to reconnect several times to see if that was the issue, but I can never connect with whichever computer is joining second. Also, if I leave the server on the first computer while the second is trying to connect, the second will almost immediately authenticate and successfully join the server. However if I then try to rejoin with the first computer, it will then no longer be able to connect.

This step:

https://winteris.moe/share/2016-04-01_17-06-33.png

And a video if you want to see for yourself:
https://winteris.moe/share/2016-04-01_17-08-33.mp4

Thank you for reading.

Try sv_lan 1 if you are only using it to test with yourself.

Added it to server.cfg, restarted the server, still the same symptoms.

https://winteris.moe/share/2016-04-01_18-35-58.png

Alright, I figured it out. It seems that if you tie the server to a Hamachi Network Interface it might do weird things involving Steam Authentication.

The reason I was doing this in my setup is because tying it to my Hamachi Interface allowed me to easily hide my development server from the Internet (because it can’t reach the Steam Servers involving Server Listings) while still having Port Forwarding enabled on my router. This meant that I could simply remove the +ip argument that’s part of my server launch BATCH Script and open it up to the Internet easily without having to go into my router and add/remove the Port Forward setting.

Hope this helps any future people from Google.