Can't Join Gmod Servers Anymore

Alright, I’ve joined this server before and it took about 30 seconds all up. But now I can’t join at all. I’ve downloaded everything. It gets to that last download the ‘MOTD’ text file thing and then freezes, and makes my superbar on my Windows 7 lag. I don’t know what’s happened. I havent installed any mods since I last could join, but I have reinstalled GMod and that’s when the problems started.
Any help is appreciated.
Thanks

Have you tried clearing your cache folder?

I’ll try that now.

Edit

That didn’t work. Any more suggestions?

When all else falls, destroy your Gmod folder

Or rename it.

Yeah, I am gunna try a fresh install tonight. My internet is slow, takes about 7 hours I think for like 3.4GB. So yeah…

Have you tried joining a different server?

Yes I have, with the same result.

It might be your firewall

No, I’ve disabled that, joined a server, still didn’t work. Now I’ve freshly installed Gmod from scratch, so I will see if servers work now.

If you remove your garrysmod folder, steam rebuilds it fresh instantly. If you delete local content then it will have to redownload.

I did both :3

Edit

Probably should of added this information at the start, but I forgot. I’ll post my system specs.

Windows 7 64-bit
Core i5 Processor
6GB RAM
Radeon HD 5450 (it’s not that good)

that should be more than enougth to run garrysmod even in high quality

you don’t have the game in your steam account…

Well you’re looking at the wrong person then…

Is this your steam account?

No, this is

Then why is it set as your account then?

What? Gmod? Because I BOUGHT IT.

http://dl.dropbox.com/u/16737046/fp/lycosa.png

Oh, right, haven’t set my profile up properly -_-\

Edit

Fixed.

UPDATE

I believe I have fixed the problem by reinstalling steam.

UPDATE 2

No, I haven’t. Please, someone, help.