Can't join into a Server

It stuck at loading connecting… please Help.
Can’t join the Eu Central Server.

I am encountering the same problem.
Try pressing F1 just as you are loading into a server, and see what errors you are receiving. I am seeing NullPointerException errors, as well as:

“could not locate a IContextRequestable – destroying self.component”.

Which sounds like the root cause of the issue.

Same problems but a friend can join and he said has the same errors.

Interesting. Well mine eventually times out and never connects. Sad.

Same error here hope they fix it soon.

Same here waited 2 hours

Same here waited days

What’s your console saying while connecting?

this is what mine says : condition still not met : servermanagement.get()(20500 frames later)
a screen of the console

I put this on our trello. It’s maybe a timeout issue… I will look into it.

Hey Garry, im having the same issue but kinda different.
I have played Rust for several days before the issue, I also happend on the webplayer.

http://imageshack.us/a/img689/3431/pcte.jpg

ulink got error: connection failed
“could not locate a IContextRequestable – destroying self.component”.

Same error as above picture…

I’m getting the same issue as you Samoth, let me know if you find a fix? I also had the same problems on the webplayer, but the server I was playing on (UK English Only) I get this error on the steam client, but didn’t on the webplayer. So all my stuff is just idling D:

OK, The problem seems fixed now… I am connected!!!

Well i havent been able 2 connect there for some while now . only the Uk servers and US . Even tho i live in eu… wierd stuff going on.

Does anyone know how to fix it ? Got the issue until the steam version

I got this issue for like 2 weeks, i can join to Aus 1 and 2, i played on UK untill server crashed… In EU Central it always stuck on the loading menu.

“could not locate a IContextRequestable – destroying self.component”.

same problem, glad i’m not the only one but we would need a fix and understand why most of ppl isnt experiencing this issue. If someone find out a solution post here please

any news on that issue ? i’ve tried reinstalling , still the same problem.

Same exact issue and i played for a full day since the server has been wiped. I suppose now my stuff will be either decayed and or raided. This error needs fixing especially for the sleeper servers.