Can't join my own server because of "older server version" and I can join all other servers.

So i’ve been trying to make a garrys mod darkrp server (so original i know) and i got it working perfectly on my local computer and so I bought a vilayer server and uploaded all my content to the server, then tried to join the server. Says the server is running an older version of the game and I can’t join, so I do a steam update, ssame issue, my co owner can join no problem, and I can join all other servers without issue. I did the steam> delete local content and re added everything and the same issue happened. Basically I can’t join my own server and i can join all others. My garrysmod has to be up to date and the cache is verified, and the server is updated to the max and there is many other people able to join my own.

Update the server…

I did. Other people can join just not me.

You sure it says server is running an older version? or is it saying client?

Seems as though changing the map twice fixed it, weirdest issue i’ve ever come across.

Well at least it works now, good luck with the server.

If you need any help with darkrp feel free to pm me.

Just asking, you’re using SteamCMD right?