Can't join my own server in Garry's Mod

So lately I thought I could host my own server for a few friends. Made a collection, got the software, mounted some things, works great.

However, when I tried joining, it got stuck at Retrieving server info…
This is what the screen looked like.

http://puu.sh/7ATMo.jpg

I tried unsubscribing to every single addon, then only subscribing to my server collection. Still didn’t work.
Removed the addons that were causing LUA problems. Still didn’t work.
I restarted Steam, changed server settings, and did lots of other things to get it to work.
It didn’t work.

I’m using SRCDS, I have TF2 and Steam mounted, a working collection with 65 or 66 addons, and I have ULX installed.
If I have to post computer specs, I will.
The weird thing is, others can join just fine, while I can’t. Why is that? Like I said, I’m eternally stuck retrieving server info, then I time out.

Please help me with this, it’s annoying.

Huh that’s like being locked out of your own house.

Now that he knows the real-world situation equivalent he is fully equipped to solve this issue. You should start posting in tech support.

On a more serious note that requires a more useful response, how are you connecting to your own server? Have you tried connecting via your local IP address?

I tried connecting through the Legacy Browser in the LAN section, but I haven’t tried localhost or 127.0.0.1. Should I try those?

EDIT: Those didn’t work anyways. They just ended up failing after 4 connections.

[editline]19th March 2014[/editline]

After some research, no one can do anything.

This is what’s happening.

edit: so it’s being dumb and forces me to download it
here
http://puu.sh/7C65e.png

that guy who plays video games is me

Notice how everyone either disconnects quickly, or times out.

So what do I do to fix it? DMZ is enabled, my ports are forwarded, what am I doing wrong?