CANT LAUNCH after new patch

Ok downloaded new patch tried:-

  1. running steam as admin
  2. joining a friend
  3. restarting PC
  4. checking game files

It just wont open now

same, post in the other thread, so far half my friends who play Rust can’t get it to launch…

Hmm, no problem here.
Just can’t join my fav. server because not updated.

+1, cant launch always crashes with error, SW issue… was running just fine 10 minutes ago -bump

having the same problem :frowning:

same here

I just updated and i can’t launch the game, i tried verify cache and reboot but nothing helped.

I tried verify, reboot, reinstall, nothing works.

Ok just tried running the EXE as administrator it says

“windows has encountered a problem and rust.exe failed to run”

It doesnt work for me either.
Which specs do you have?

I have

CPU Intel 3570K
Graphics MSI 660 TI
OS Windows 7 Ultimate

surely they test these things before they deploy right?

apparently not, keep it on top… bump

For me its working, but there are many guys complaining about that on steam too.

Good luck for you all :>

Amen to that, Bumping. Kinda sad. Over 400 hours invested into this game, without a single complaint. And one of the most amazing update’s i’ve seen. or been excited for hits. And I get to sit on the sidelines listening to all my friends Go crazy for the changes, I’ve Restarted my computer, uninstalled 4 times, checked my integrity of cache files, I’ve tried everything on the first three pages of google, as well as everything my years of gaming have taught me. And still un-able to even get to the resolution screen. Insta crashes with “rust.exe has stopped working”

I just reinstalled Rust completely and couldn’t launch my game. So I right-clicked Rust in steam, went to properties, and selected the “Betas” tab, then set my game to be in the dev branch. After doing that my game launched just fine.

it worked for me :smiley:

Do you have a virus detector? Is it falsely detecting Rust as a virus?

Did you try this: http://www.facepunch.com/showthread.php?t=1360075

Try to run steam as administrator

Reboot your PC all the way and try again. Should resolve the issue.