Can't launch Rust. Rust "Launcher Error: LauncherFailure - StartService failed (1275)"

Hi, I recently got a new motherboard (MSI 970 Gaming) and CPU (AMD FX8350 8Core) and was having a lot of problems with windows and old drivers. (Keep in mind that I have had this new hardware for about 5 days and Rust was working fine before the following) These problems made me have to uninstall and reinstall windows due to all of the BSODs I kept getting. Now, after doing so, I tried to launch Rust and i got the following error: Rust Launcher Error: LauncherFailure - StartService failed (1275) I don’t even get to go into the launcher. I’ve been googling this error for a few hours now to no avail.

Things i’ve tried:

  1. Uninstalling and reinstalling EAC.
  2. Uninstalling and reinstalling Rust.
  3. Verifying the integrity of the game cache.
  4. Deleting all EAC related items in the Rust directory and then Verifying the integrity of the game cache.
  5. Turning off my antivirus.
  6. Allowing Rust through my firewall.
  7. Excluding Rust from my antivirus.
  8. Restarting my computer.
  9. Launching Rust through the Rust directory. (Works but i can’t join any server due to EAC)
  10. Launching Rust as an administrator.

My specs:

Mobo: MSI 970 Gaming.
CPU: AMD FX8350 8Core.
GPU: Gigabyte GTX 960.
RAM: 12gb 1600mhz DDR3 Crucial Ballistix Sport.
Heatsink: Coolermaster Hyper 212 EVO.
Case: NZXT Phantom 530.
HDD: 7200rpm 1TB (Unsure of the name)
PSU: EVGA 500w 80+ Certified

Facts:

  1. I usually run Rust at 60-100fps with settings labeled as “Good”
  2. My CPU temp never seems to rise above 65°C while playing Rust.

I straight up just can’t launch the game and i’m out of things to try. Please reply ASAP because i’d like to finish working on my base :slight_smile:

Something on your system is blocking EAC from starting, it seems. I’m not one of the EAC devs so I defer to them for a more detailed and probably more accurate answer, but have you disabled driver signing verification or enabled test mode?

I have no idea what either of those are and I forgot to add that I have updated Windows and everything is up to date.

What antivirus and firewall are you using?

Windows Defender and Windows Firewall… xD I did try to install Malwarebytes yesterday but it won’t open no matter what I do and it won’t let me uninstall it either.

I think there’s something going on with your computer beyond Rust being unable to load, but I’m not quite sure what it is.

Here’s what I’d suggest as a baseline:

  1. Open a command prompt as administrator

  2. Enter this command:


sfc /scannow

  1. Once the computer’s finished, reboot

Done, no issues found. Rebooted and still can’t launch Rust.

This might help,

  1. Go to program files x86
  2. Steam
    3)Steam Apps
  3. Common
    5)Rust
  4. Then open up the folder named “EasyAntiCheat”
  5. Run EasyAntiCheat.setup.exe as admin and install it
  6. Open up rust and it should work. -still doesn’t work? reboot and try again.

if it doesn’t work, make sure windows is up to date. if it isn’t, download all updates. expect language updates.

Sorry but I already stated that I tried both of those to no avail. :confused:

Well, thanks for your help but i just ended up uninstalling and reinstalling windows and all of my apps. That seemed to fix it.

Hi,

You can check the service errors from here: https://msdn.microsoft.com/en-us/library/windows/desktop/ms681383(v=vs.85).aspx

Error code 1275:

This means that something in your system is preventing EAC’s driver from loading. Could be anti-virus sofware, malware/virus/trojan/rootkit infection etc.