Can't load experimental up today?

So I got the f***** grey screen of death on the legacy version… and so I’ve been playing only experimental for the last 3-5 days…

And I go to load up today to see if anythings changed and I can this:

"This program wants to make changes to your computer

               Easyanticheat LTD

Allow?"

And whether I allow it or deny it, Rust fails to launch… anyone else seen this?

Literally the top thread when you created this one contains this post from one of the EAC guys:

Follow these steps to manually install EAC. Then see what Rust does.

Also, do you have a security suite installed?

Yeah i just saw that thread when I posted this.

Security suite? like antivirus?

I have AVG…

I’ll try those tips

Make sure AVG has exceptions for Rust.exe and RustClient.exe in the experimental folder inside Rust’s Steam folder.

Tried it. no luck.

Created shortcut, added “install 12” (without quotes)

Tried to run as administrator, a command prompt window flashed super fast… then nothing…

Disable AVG and try.

Interesting…

I am able to launch Rust (experimental) from the shortcut in the steam folder. But if I try to launch it directly from steam I get the same error.

[editline]18th July 2014[/editline]

I disabled AVG and it still won’t boot from inside steam.

Which exe are you clicking when you run it directly?

RustClient inside the “experimental” folder

BUT I just loaded in, and it kicks me out of the server im in after 15-20 seconds.

SO conclusion:

Can’t load Rust from Steam.

I can go into Steams folders and load rust that way.

But when I do, it kicks me out of the server in about 15-20seconds.

Running RustClient.exe directly means you’re not loading EAC, and that’s why you get kicked.

Makes sense.

Just wondering what changed from yesterday :confused:

I was able to load up experimental version not, 10 hours ago.

Tried reinstalling…

Garry, it’d be nice if you could comment on this. All your shits fucked up.

Can’t play legacy because of some unknown error (that lots of people are having)

and now magically can’t play experimental because of some unknown error (that lots of people are having)

Hi Dewm,

After starting Rust Experimental from Steam, if you wait a moment do you get any error messages pop-up? Is the Rust.exe or RustClient.exe is still running in the processes list forever (CTRL+SHIFT+ESC)?

I’m having the same exact problem. When i tried to load rust from steam and choose the experimental version a box appears and says this.

Rust Launcher Error: InstallationError - EasyAntiCheat installation failed; EasyAntiCheat installer failed to acquire sufficient privileges.

How can i fix this so i can play?

Try the steps in the second post of this thread.

Come on now. I wouldn’t have posted this if I haven’t tried the solutions that were given in this thread. That obviously didn’t work for me.

Try running Rust.exe (not RustClient.exe) in the experimental folder inside (Steam directory)\steamapps\common\Rust\ as administrator. Make sure you’ve gone into properties and, if the button is active, clicked “Unblock”.

If you have already done that without success, it might be helpful to detail the steps you’ve already taken so I or anyone else don’t continue to waste your time.

Also, is the Windows account you’re logged into an Administrator?

None of this works. I get the same message from EAC. It’s obviously an issue with them and there oh so great software

Hey guys, any resort to this problem? I just got EAC-ed with this error after joining my localhost experimental server, now I can’t play rust at all. I tried everything, even reinstalled rust…:frowning:

http://forum.facepunch.com/showthread.php?t=1430519