Can't load server.cfg

Hi, so im trying to run an experimental Rust server and i don’t know why server.cfg is not loading. My Server Start bat file contains the fallowing…


@echo off
set IDENTITY="GrimKeep"
RustDedicated.exe -batchmode -server.hostname "Grims Oxide Server" -server.port 28015 +server.identity %IDENTITY% +server.maxplayers 2 -cfg "server/%IDENTITY%/cfg/server.cfg" -load "server/%IDENTITY%/save/0.sav" -logFile "server/%IDENTITY%/logs/rust_%DATE:~-7,2%-%DATE:~-10,2%-%DATE:~-4,4%.txt"

The server.cfg file is located SteamCMD\steamapps\common\rust_dedicated\server\GrimKeep\cfg and contains


rcon.password "xxxxxxx"
env.time "12"
env.daylength "99999999"
censor.nudity true
server.pvp false
crafting.instant true
server.clienttimeout "30"
airdrop.min_players "1"
truth.enforce true

Anything wrong with my setup?

It is due to the fact that the cfg folder needs to be made in the Main root folder where rustserver.exe is so you would need to put the rust.cfg in the SteamCMD\steamapps\common\rust_dedicated\cfg folder and yes you will need to make this.

[editline]4th October 2015[/editline]

Plus -cfg only worked for the non-experimental.

  1. Find RustDedicated.Exe
  2. Make a folder called “cfg” under it
  3. Put your cfg file in there and call it server.cfg

You don’t need a command line to load it, it will just load it if it’s there. That’s the only place you can put it.

Also be careful, some command line options do not work within the cfg file because it is loaded after some of the initialization has already been made. I don’t remember which, but I think the seed and world size are two of them.

Guys, this user hasn’t come back to the forum since posting this thread back in June.