Cant loot

I can play the game perfectly fine for about 1-5 minutes, then all of a sudden i cant loot boxes, trees, rocks or anything anymore. I cant fight mobs either, but they can kill me. It’s extremely frustrating, this happened while the game was browser based, and it still happens, this doesn’t happen to any of my friends, and i can’t find any fixes anywhere. My drivers are all updated i’ve tried reinstalling but that did not help.

It’s internet lag.
If you can move fine, but can’t open doors/storage boxes, than it means that something is wrong with your connection to the server.

it happens on all servers, also i dont have any connection problems in any other games, just rust.

bump

Same here. In order to play I have to net.disconnect and net.reconnect about every 4 minutes. Seems like a network timeout or certain messages get dropped or garbled without recovery. Once the server has stopped listening for my movement/coordinates and I end up running around oblivious until:

  1. I try to loot and find the loot panel doesn’t appear
  2. gather resources and don’t get any console msg with the results of the loot
  3. I hear radiation but see zero on my rad level
  4. a friend tells me that I’ve stopped running (and an animal may be attacking my **frozen body **(which I do take damage from) to add to the frustration… then I die while I’ve been thinking that I was far enough away.
  5. (this one is not reliably repeatable but…) sometimes can’t place a crafted object

As well, ** No new Zombies, player made structures, or ore nodes appear other than those already rendered.**

I can open doors fine and even open doors for other players (to the other player it’s like a ghost opened a door) so the world still responds somewhat to my actions.
So this in total looks like a timeout issue only instead of the server disconnecting me it lets me carry on until I interact and realize the long distance I just ran was for nothing as my body actually didn’t move for the past few minutes. This issue is a little different for some servers as the time may vary which I think still leads to a timeout.

Loading Trees:
The latest issue since yesterdays patch is the crash when trying to load the rust map or trees. The loading trees issue seems to me that the server simply can’t determine a spawn point for me. The reason I say this is because I was on the server before but I figure I died or my body was killed; and when I see 'loading trees’ I can hit escape and see the **‘random respawn’ or ‘camp respawn’ **options on a black screen only I can’t move the mouse to select an option. So my spawn location is in limbo.

Exactly, same thing for me, its impossible to play this game, it seems there are a few others with this problem but no fix at all. it sucks having to spend 30-50 seconds disconnecting and reconnecting every 4 minutes, this game is fun but not in 4 minute increments. I hope someone can help us.

Could you guys confirm that occasionally these things below happen as well when your noticing the other issues described in the post?

  • unable to switch weapons
  • unable to throw grenades or drop item sacks
  • chat does not pop up automatically or messages show up very briefly

I just achieved some success on the ‘gowing trees’ / ‘loading’ character’ issue for me. I’m using an NVidia 8800GT.
I wasn’t aware of the OpenGL switch so I tried it and now I can get past a loading screen and into the map.

Game Startup flags that I’m aware of pertaining to graphics:
-force-opengl
-force-d3d9

-force-opengl worked for me. Try either.

[edit] Additional flags you can try: (found these in the forum)
-force-d3d11 -force-feature-level-9-3
-force-gfx-direct
So from these flags you can see that you could try different versions of DirectX that might be compatible. DirectX 9/10/11 (d3d11 = Direct 3D version 11)

To do so…:
Within Steam goto rust. properties. On the General tab -> ‘Set Launch Options’ button.

Once in the game, before joining any server I enter in console (F1) what I assume to be a memory/poly leak fix:
grass.on false

I still could not gather any resources though so that issue is still outstanding. I reconnected and was able to gather resources. But disconnected for this post. I’m assuming that I’ll post back in 4 minutes to tell you that I can gather :frowning:

ive got -force-d3d11 on launch options and that helps with any graphics issues, but i still have the no looting problem.

I’ve had a hunch that I was missing out on chat once I realized I was dropped.
Switching weapons has never been an issue.
Dropping item sacks and throwing grenades will take awhile to test as the first I’ve been able to play since 2 days is now (+server reset). Takes a very long time to get established reconnecting.

[editline]15th November 2013[/editline]

I’ll note that I’m running 32bit XP (which my friend has crucified me for. But my system is extremely OCDish clean and runs everything nicely. My hunch is that this is a Q3 engine so I figure I’m perfectly compatible.

[editline]15th November 2013[/editline]

I mentioned that -force-opengl worked for me however there’s a slight downside. When I exit the game I hear the game crash sound and then My desktop is left in the in-game resolution. I can live with that for now :stuck_out_tongue:

[editline]15th November 2013[/editline]

Separate bug: Another issue I’ve noticed is that the ‘use’ key cannot be rebound in-game. You have to rebind it in the launcher window (world use’)

[editline]15th November 2013[/editline]

Messages so display fine.

Apparently I can attack other players while ghosting. I ran inside another guys hut. He ran out. He came back in and lit his campfire. I started chopping away but he had no idea how he was getting hurt. (sorry dude/whoever)

really hope we can get some insight on how to solve this problem.

Same for me, only started happening today.

tried on 6 different server and get same thing.

Able to log in fine, can play for 3 mins or so, then theres a slight glitch (like ive been de-synced to the server) after that unable to gather or loot items

if i reconnect it repeats the process

I have a few suggestions, give them all a go.

  1. In Steam set the Launch Options to ‘-force-d3d11’
  2. Try running the Dev build, if you are running the dev build try the regular build.
  3. Do you have 2GB FREE memory?
  4. Lower your graphics settings.

ive done everything here, plus i have 16gb of RAM so i hope the memory wouldnt be the problem, also i always do “grass.on false” in the console, all of these things have eliminated graphics lag for me, but unfortunately i still have to disconnect and reconnect every 4 minutes.

I’m having the same issues listed above. I desync from all the servers. Can’t loot, can’t mine from generated piles on the map BUT I can gather from trees. I go into rad zones, hear it, but it stays at 0. Also, the loot won’t spawn. There’s also no animals that spawn.
My specs -
Windows XP 32 bit
GTX 550ti x2 SLI
3gb DDR2 ram
Intel Core Duo E8400
Several 500gb drives
Coolermaster 750w

XP? O.o Wow! I’m surprised people still use XP today.

Hey, same for me but i have one different. Im losing my connection after some seconds…
And the game is working on every other computer at home instead of mine :confused:

bumb

Very frustrating. Been trying since yesterday to get cloth or a sleeping bag back to my hut (I claimed an abandoned house). Hard to get anywhere when your body is back getting mauled by zombies,wolves, or players. 3 minutes of gameplay to gather a few mats and then you’re body is vulnerable while you think you’re making progress running like Forest :frowning:
It would be better to simply get disconnected instead of not knowing that you’ve left your body behind somewhere. Is there a netgraph for the game? I can see spikes in an external meter I use whenever I encounter players or player made structures.