Can't mount CS:S to my Linux server [Ubuntu 16.04]

Hi there!

I have read almost ALL of the threads about this topic. I have tried every suggestion that they gave but nothing worked.

Some questions you may ask me:

Q: Have you tried putting it in your main server directory?
A: Yes, yes I have. I have put it in my /home directory, root directory, and the server directory.

Q: Have you updated DarkRP?
A: Yes. I updated before I posted this but it still did not work.

Q: What are your file permissions for the cstrike.
A: The permissions are set to 777 just to be safe.

Q: Have you used SteamCMD to update and validate the CS:S files?
A: Yes. This was one of the first things I have done.

Q: Can we see your mount.cfg?
A: Sure, it will be pasted right below this.



"mountcfg"
{
	 "cstrike"	"/home/content/cstrike"
	// "tf"	C:\mytf2server	f"
}


Some more background info:

I recently changed operating systems to allow me to install the Pterodactyl Panel. All of my servers were working fine until I backed them up and re-added them after changing my OS.

Correct me if I’m wrong, but wouldn’t the dir be /home/machineuser/…

No because I put the files just in the home directory. I am not limited to my “machineuser” directory.

Where is your server directory?

The server directory is in


/srv/daemon-data/egndrp_17be7ecb

However, I have moved the content into


/srv/daemon-data

and changed the mount.cfg but it still did not work. At the moment, it is currently in that directory.

If you place both the server folder and the cstrike folder in the same directory, there is no reason for it to not mount.
The only thing that could be messing it up is the folder itself

What’s the content of the cstrike folder?

The content of the cstrike folder is whatever the SteamCMD downloads.

You mean from when you download a cstrike dedicated server? Because if so, you need the cstrike folder inside that one (So the path looks something like: “/path_to/cstrike_server/cstrike/cstrike”)

I have tried that but I will try again.

Try running Chmod on the folder

have you tried hosting somewhere if_else> instead? else!

Already done that…

[editline]8th May 2017[/editline]

I can’t because the panel I use puts it in those folders and I can’t change that.

How’d it go?
As I said

So unless your server is seriously fucked, it should work (Just link the correct folder)

If it still doesn’t work, try mounting it on a clean server.
If it works on the clean server, something’s messed up with your server.
If it doesn’t work on the clean server, either you’re doing something wrong or shit’s fucked

I’m sorry for bumping this, but I want to post the solution to this so other people can fix this issue.

This is an issue with the Pterodactyl panel itself and the way it handles files.

Your server directory is in “/srv/daemon-data/egndrp_17be7ecb/data”
Put your cstrike data in the same directory as the server. So like “/srv/daemon-data/egndrp_17be7ecb/data/content/cstrike”

Now put this in your mount file:



"mountcfg"
{
	"cstrike"    "/home/container/content/cstrike/"
}


Now it should work :slight_smile: