Can't mount cstrike to gmod server (ubuntu)

So, before we start I want to say that I’ve googled for maybe an hour and have NOT fixed my issue.

This is my startup log (I removed addon startup things):


steam@GMOD:~$ ~/server_1/srcds_run -game garrysmod +maxplayers 16 +map gm_construct +gamemode darkrp
Auto detecting CPU
Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
Couldn't load shader dll: game_shader_generic_garrysmod_srv.soConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for Workshop..
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Fetching Workshop Addons.. No -authkey
Adding Filesystem Addon '-snip-'
Unknown command "cl_cmdrate"
Unknown command "cl_updaterate"
Unknown command "rate"
Changing gamemode to DarkRP (darkrp)
Network: IP 127.0.1.1, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Error loading cfg/trusted_keys_base.txt
Error loading cfg/pure_server_minimal.txt
PREP OK
HTTP failed - ISteamHTTP isn't available!
HTTP failed - ISteamHTTP isn't available!
HTTP failed - ISteamHTTP isn't available!
HTTP failed - ISteamHTTP isn't available!
HTTP failed - ISteamHTTP isn't available!
HTTP failed - ISteamHTTP isn't available!
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file server.cfg
Using map cycle file cfg/mapcycle.txt.
HTTP failed - ISteamHTTP isn't available!
Nav File is wrong or something (4)
Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
No account token specified; logging into anonymous game server account.  (Use sv_setsteamaccount to login to a persistent account.)
Server logging enabled.
Server logging data to file logs/L0206004.log
L 02/06/2017 - 16:31:15: Log file started (file "logs/L0206004.log") (game "/home/steam/server_1/garrysmod") (version "6614")
'banned_ip.cfg' not present; not executing.
Writing cfg/banned_user.cfg.
Connection to Steam servers successful.
   Public IP is xx.xxx.xx.xx.
Assigned anonymous gameserver Steam ID [-snip-].
VAC secure mode is activated.


My mount.cfg is the following:


//
// Use this file to mount additional paths to the filesystem
// DO NOT add a slash to the end of the filename
//

"mountcfg"
{
	"cstrike"	"home/steam/server_1/garrysmod/cstrike"
	// "tf"			"C:\mytf2server	f"
}

My FTP screenshot to prove that cstrike is on the right location:

My ls- al in the garrysmod directory:


steam@GMOD:~/server_1/garrysmod$ ls -al
total 717804
drwxrwxr-x 22 steam www-data      4096 Feb  6 16:31 .
drwxrwxr-x  8 steam www-data      4096 Feb  5 15:05 ..
drwxrwxr-x 33 steam www-data      4096 Feb  5 14:02 addons
drwxrwxr-x  2 steam www-data      4096 Jan 20 18:36 backgrounds
drwxrwxr-x  2 steam www-data      4096 Jan 20 18:36 bin
drwxrwxr-x  2 steam www-data      4096 Jan 21 12:26 cfg
-rw-rw-r--  1 steam www-data     83823 Feb  6 15:44 clientside_errors.txt
drwx------  9 steam www-data      4096 Feb  5 15:01 cstrike
drwxr--r-- 12 steam www-data      4096 Feb  5 13:52 data
-rwxrwxr-x  1 steam www-data     31452 Jan 20 18:33 detail.vbsp
drwxr--r--  3 steam www-data      4096 Jan 20 18:38 download
drwxr--r--  2 steam www-data      4096 Jan 20 18:37 downloadlists
drwxr--r--  3 steam www-data      4096 Jan 20 18:37 downloads
drwxrwxr-x  2 steam www-data      4096 Jan 20 18:36 fallbacks
-rwxrwxr-x  1 steam www-data  30613491 Jan 20 18:33 fallbacks_000.vpk
-rwxrwxr-x  1 steam www-data     47681 Jan 20 18:33 fallbacks_dir.vpk
-rwxrwxr-x  1 steam www-data      1028 Jan 20 18:33 gameinfo.txt
drwxrwxr-x  6 steam www-data      4096 Feb  1 17:09 gamemodes
-rw-rw-r--  1 steam www-data        16 Feb  6 16:30 GameState.txt
-rwxrwxr-x  1 steam www-data 234817516 Jan 20 18:35 garrysmod_000.vpk
-rwxrwxr-x  1 steam www-data 234173429 Jan 20 18:35 garrysmod_001.vpk
-rwxrwxr-x  1 steam www-data 233984978 Jan 20 18:35 garrysmod_002.vpk
-rwxrwxr-x  1 steam www-data    616558 Jan 20 18:34 garrysmod_dir.vpk
-rwxrwxr-x  1 steam www-data        40 Jan 20 18:33 garrysmod.ver
drwxrwxr-x  6 steam www-data      4096 Jan 20 18:36 html
-rwxrwxr-x  1 steam www-data      1934 Jan 20 18:34 lights.rad
drwxr--r--  2 steam www-data      4096 Feb  6 16:31 logs
drwxrwxr-x 14 steam www-data      4096 Feb  2 20:58 lua
drwxrwxr-x  3 steam www-data      4096 Jan 22 18:25 maps
drwxrwxr-x  2 steam www-data      4096 Jan 20 18:36 media
-rw-r--r--  1 steam www-data      6900 Feb  6 16:31 modelsounds.cache
drwxrwxr-x  2 steam www-data      4096 Jan 20 18:36 particles
drwxrwxr-x  6 steam www-data      4096 Jan 20 18:36 resource
drwxrwxr-x  2 steam www-data      4096 Jan 20 18:36 scenes
drwxrwxr-x  4 steam www-data      4096 Jan 20 18:36 settings
-rw-rw-r--  1 steam www-data         0 Feb  6 16:30 stats.txt
-rwxrwxr-x  1 steam www-data        58 Jan 20 18:34 steam.inf
-rw-r--r--  1 steam www-data    512000 Feb  6 16:31 sv.db


If anything else is needed I’ll try to provide. But I’m quite desperate for help… :confused:
I’m using a CSS addon on my client and keep getting the darkrp error :confused:

Incorrect


//
// Use this file to mount additional paths to the filesystem
// DO NOT add a slash to the end of the filename
//

"mountcfg"
{
	"cstrike"	"/home/steam/server_1/garrysmod/cstrike"
	// "tf"			"C:\mytf2server	f"
}

Whoops, guess that was my mistake… :confused:

Thank you! :slight_smile: