Can't open console!

I enabled the console in the options and it’s supposed to open with the ~ button but it doesn’t!

can someone please help me?

Sure you’re pressing the right button?

Yes!It says I have to press “~” but it doesn’t work!

Try pressing other buttons, in that general area.

Wait, the ~on my keyboard is next to enter, and where # is usually is there’s a `. Wierd.

Bind your console to something else (like F12)in your autoexec.cfg config file. I can’t remember the exact console command (something like “+toggleconsole”) so you will maybe have to Google it…

[editline]06:12PM[/editline]

Also, the button to press isn’t “-” it’s either ’ or ~.

Try the button above Tab.

I did!

[editline]04:18PM[/editline]

I did try the ~ button!
also wheres the config file?

garrysmod\garrysmod\cfg

Oh god, just right click on gmod, the properties, then startup options or something, type in -console

steam/steamapps/your steam name/garrysmod/garrysmod/cfg

Or you could just click on Gmod in steam, click properties and set launch options. write in -console.

Do you have it enabled in Options -> Keyboard -> Advanced Settings?