cant open console

Ok, so I have this issue with source in general that since I use a swedish-layout qwerty keyboard, my tilde-key is located in a different spot, replaced by the § key. In source, this means that I cant use “alt gr + ¨” (my tilde (~) key) nor § top open the console. Pressing shift+alt to change keyboard layout does not help.

I have always used the standard fix for this, which was to add “-console” in the launch parameters. However, this stopped working for quite some while ago, but some time after that I was happy to discover that there was a bind to toggle console added to the options-keyboard menu.
I have been using this for some time, although it is not flawless, since it requires me to be in a game to use it, and I can’t use it in the main menu. Heard people using tilde had issues with this as well, but solved it by holding down the key. Did however not work for me.

This has not really been much of an issue, but recently I decided to update all addons I used to have.
After updating them, I renamed my old addons folder (with the updated addons) back to “addons”, and the clean/empty one to “addonsBACKUP” making gmod use the addons again.
Starting a singleplayer game to see how much is broken and which addons I need to sacrifice/delete (or fix myself), I noticed that, for some stupid reason unfathomable by me, gmod kicks clients when they get lua errors (seriously, this is as idiotic as when I noticed gmod accidently disables clientside lua by default).
This proves to be pretty annoying, since I cant fix the errors without the console, and I cant open the console without entering a game, which I cant enter since I get errors.

I tried using “sv_kickerrornum 0” in various config files to stop the crash-to-main-menuing, but cant find one that makes it work, and I dont know any automatic console-log for gmod.

TL;DR
I cant open the console in main-menu. I use a swedish-layout qwerty keyboard so tilde is not an option.

As a side note, alt + f4 seems broken as well. It is extremely annoying with a game that refuses to close down unless I alt-tab and manually press the “” button on the window.

in “garrysmod/garrysmod/cfg/” put a file called “autoexec.cfg”
in autoexex.cfg put



bind <KEY YOU WANT> toggleconsole


then start gmod and press that key… Fixed :smiley:

OR: Try pressing alt. Then if that doesn’t help, say: “; toggleconsole;” WITH QUOTES.

Hope someone helps you with this issue, but as a note, Alt+F4 doesn’t work in source games anymore.

Is this not the same thing as binding a key in options-keyboard? As in, only works in-game and not in main-menu?
EDIT:
tried this despite that, but no, didnt work.

Yeah cause that works in the main-menu

Thanks for the info. :slight_smile:
I wonder if they are going to fix that bug some day.

Mine works, you have to hold the button on the main menu, it’s delayed.
For example, I used - bind l toggleconosole - and then pressed l(L), and it opened.

How long did you hold? cause as I said in OP I already tried holding it down, but that was only around 10 seconds.

You should only have to hold it for 2 seconds, I tested it before I posted it.

bump
So noone got any solution?

Do you need me to help you because if it’s a bind, my solution works.

if doesnt work, open the options menu, then try pushing the tide key

Obviously he tried that.Have you tried bind key’s in console?

I tried binding toggleconsole manually yes, as I said in an earlier reply.

I can report that since I tried a few different things, I found that when I tried binding one of my already busy keys (a to z) it actually is possible to open it in the main menu. For some reason, using f10 as the bind only works in-game, while trying ‘l’ as panda says he uses (tried it since he said it works for him), it actually works.
I dont really want to use one of those keys though, since they are already busy with all sorts of commands. Although I suppose I can move one of them to my g# macro buttons (I use a g19 keyboard) if I have to…

Anyone knows why the function keys does not work unless in-game?