Can't pick up weapons ded server

attempted to create unknown entity type weapon_real_cs_grenade

This happens with every weapon I spawn, it doesn’t float though like some other people it falls to the ground like it should but when I press “E” nothing happens, I can however spawn weapons from the weapons menu and use them but how are other people supposed to pick up these weapons.

Help will be greatly appreciated I have been stuck on this for days now. Noone seems to be able to help.

Anyone?

installed CSS?

CSS is installed yes. I just don’t know why when I buy a weapon I can’t pick it up.

I am assuming from that post that you are using DarkRP.
If so, you need to disable gun licenses to be able to pick up purchased weapons… Try the console command:

** rp_license 0 **
Also can be disabled from the F4 admin tab, along with everything else.
This should solve your issue.

Else check that you can spawn normal CSS Weapons. Sometimes you need to install CSS as a addon.

I have tried that but it does not work. Thanks for replying anyway.

[editline]04:32PM[/editline]

I can spawn them straight from the “q” menu only.

Nevermind reinstalling darkRP worked