Can't play demos

I have no clue of when this started but it seems as if I’m receiving quite a few different errors whenever I try to play a demo, hopefully someone has a clue as to what is causing this.

When I try to play demos in-game via console:

Most of the time I just get the “Netchannel: failed reading message net_SetConVar from unknown.”, tried looking it up but didn’t have much luck.

edit: Seems as if I’m having similar issues in CSS, keep getting the following errors if I try to play them via console:

If anyone could provide a solution I would really appreciate it.

edit: Reinstalled Garry’s Mod, still having the same issue :confused:
edit2: Seems like the issue is with demos I record, I sent a friend one of my demos and he couldn’t view it.
Here’s a link to said demo if anyone wants to test it: http://www.mediafire.com/?2tpf4dj9bb5htgc
edit3: Had a friend try recording a demo and neither of us can view it, is everyone having this issue?

yeah, i have the same problem:

Still not fixed after today’s update.

I’ve got this too.
Really wish it’d get fixed, recording demos and then capturing them is definitely easier than capturing while trying to act.

Put in a ticket about the issue on CSS and received this reply:

Doesn’t seem to have helped for CSS though it did fix the issue on GMod (though any old demos I have are still broken).