cant play gmod10 on windows 7

as it says above i cant play gmod online with windows 7,its just too laggy i cant even play,i can get into servers but i can barely play because of all the major lag,so i would like to know what could fix this,my friend suggested reformating my computer again although i just did,so are there any other ways to fix this problem?

you should try looking in the options
go to video

go to advanced

pic all the options with * besides them, there the best for your computer, try it, it should help

ok i will try that,thx

Edit:

nope everything has a star next to it,any other things i should try? (other then re-format)

trust me, it should probably work

i, myself, also have a windows 7

What are your specs

umm…im not really sure,is there any way to see them?,anyways though,before i got windows 7 it worked perfectly fine,but now after i got windows 7 it lags alot,so i dont think the specs would be my problem

how much ram do you have!!!

Press start, type Dxdiag, and then select “Save all information”. Open the .txt and copy pasta it here.

Then put in in [noparse]




[/noparse] tags

Operating System: Windows 7 Home Premium 32-bit (6.1, Build 7600) (7600.win7_gdr.091207-1941)
Language: English (Regional Setting: English)
System Manufacturer: System manufacturer
System Model: System Product Name
BIOS: BIOS Date: 07/13/07 21:27:16 Ver: 08.00.12
Processor: Intel® Core™2 Quad CPU Q6600 @ 2.40GHz (4 CPUs), ~2.4GHz
Memory: 2048MB RAM
Available OS Memory: 2048MB RAM
Page File: 1766MB used, 2327MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled

is that what you needed to know?

Ok one of your problems is that you have very little ram, i think that is 2GB right there. My old computer had 1.89GB and it had about the same problem. I got a new computer not too long ago that has windows 7 and it works just fine because it has 8GB of RAM , one thing i need to know though, what is your video card?

the ram is fine he doesnt have to get more ram it has something to do with his gpu or something else

well my video card is Card name: NVIDIA GeForce 8800 GT
Manufacturer: NVIDIA
Chip type: GeForce 8800 GT
DAC type: Integrated RAMDAC
and im not sure what my GPU is

A GPU is your videocard.

How fast is your Internet connection

oh sry lol

[editline]02:59AM[/editline]

im not really sure how to see that either…lol sry

go to www.speedtest.net

ok thx, http://www.speedtest.net/result/770093908.png

there we are 512ms lag on a speed test, you have a slow Internet connection, consider a upgrade or buy a new router and connect via a cable to it.

ok thanks i will try that

[editline]04:54AM[/editline]

ok well actually i played CSS online for a little while and it worked fine,no lag or anything,so i dont think its my internet connection