Can't play singleplayer in some gamemodes.

I’m making a map, For my TTT server, So when I want to test it in TTT it doesn’t work.

I’ll explain.

So I start up garry’s mod, I select singleplayer, I choose my map, then select the TTT gamemode and launch the game, It loads to about halfway untill it stops on “Loading resources” And crashes 5 minutes after that. I have Verified my Cache, I’ve uninstalled all the addons that have been ‘creating script errors’

And Idk what to do from here, Anyone know?

Have you tried starting TTT on another map? The issue may be isolated to your map only. Just tested TTT in singleplayer with a few custom add-ons and I’ve no crash.

Alternatively you could try starting a multiplayer (local) server and see if it crashes.

tried both of those tips, nothing seems to work.

You said you uninstalled all the addons that were ‘creating script errors’ (why would you keep them until now tho?), but what about others? Try disabling every addon and see if it works.

Also, does this happen only with TTT?