Can't remote connect (rcon) to my server. Command-line inside.

I’m trying to remotely access my server but my connection is refused every time. I’ve been reading into why it might not be working—try +rcon.ip 0.0.0.0, etc—but I’m not having any luck. It’s pretty much the only feature I’m missing from my server before I am comfortable launching it.

Here’s my command-line, with the rcon password obfuscated, naturally:


RustDedicated.exe -batchmode +server.secure false +server.hostname "RustReboot Server" +server.port 28015 +server.maxplayers 150 +server.identity "IS_RustReboot" +server.seed 28015 +rcon.port 28016 +rcon.password "password" +server.saveinterval 3600 -logFile "output.log" -load

Connecting via the web console in my game panel gives me this error:

Using tools like Rusty also deny my connection.

Any suggestions?

An exception along those lines usually means there is a firewall in the way or ports not configured correctly.

If hosting your own from home make sure the rcon ports are forwarded UDP in windows firewall. Hard to say because you haven’t given much info on your setup, i.e.

  • What OS is the server running on
  • Whats the firewall status, on or off?
  • You’ve tried 0.0.0.0 for rcon.ip, have you tried the rcon.ip + the server ip?
  • Have you forwarded the ports in your router properly?

I can verify the settings when I get home as rcon works ok for me and I have helped a few guys set up thier servers for rcon also.

+rcon.ip 0.0.0.0