Cant run map.

So i finished my map and everything but now it wont let me run the map. Everytime i try to run the map on my TF2 game i get this

CModelLoader::Map_IsValid: No such map ‘maps/HellzHero.bsp’
map load failed: HellzHero not found or in

I have pressed Alt+P to find any problems and none show up.

I have compiled it many times with no errors to my sight coming up.

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\hellzhero666\sourcesdk\bin\orangebox\bin\vbsp.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\hellzhero666 eam fortress 2 f” “C:\Program Files (x86)\Steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.vmf”

Valve Software - vbsp.exe (Apr 26 2012)
8 threads
materialPath: c:\program files (x86)\steam\steamapps\hellzhero666 eam fortress 2 f\materials
Loading C:\Program Files (x86)\Steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.vmf
ConVarRef mat_reduceparticles doesn’t point to an existing ConVar
Patching WVT material: maps/hellzhero’s map 2/nature/blendgrass_canyon02_wvt_patch
fixing up env_cubemap materials on brush sides…
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
Processing areas…done (0)
Building Faces…done (0)
Chop Details…done (0)
Find Visible Detail Sides…done (0)
Merging details…done (0)
FixTjuncs…
PruneNodes…
WriteBSP…
done (0)
writing C:\Program Files (x86)\Steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.prt…Building visibility clusters…
done (1)
Creating default LDR cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors…
Finding lightmap sample positions…
Displacement Alpha : 0…1…2…3…4…5…6…7…8…9…10
Building Physics collision data…
done (0) (80837 bytes)
Placing detail props : 0…1…2…3…4…5…6…7…8…9…10
Water found with no water_lod_control entity, creating a default one.
Compacting texture/material tables…
Reduced 200 texinfos to 141
Reduced 53 texdatas to 46 (1457 bytes to 1138)
Writing C:\Program Files (x86)\Steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.bsp
1 second elapsed

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\hellzhero666\sourcesdk\bin\orangebox\bin\vvis.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\hellzhero666 eam fortress 2 f” -fast “C:\Program Files (x86)\Steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2”

Valve Software - vvis.exe (Apr 26 2012)
fastvis = true
8 threads
reading c:\program files (x86)\steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.bsp
reading c:\program files (x86)\steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.prt
791 portalclusters
2354 numportals
BasePortalVis: 0…1…2…3…4…5…6…7…8…9…10 (0)
Optimized: 13846 visible clusters (2.88%)
Total clusters visible: 480991
Average clusters visible: 608
Building PAS…
Average clusters audible: 789
visdatasize:162273 compressed from 164528
writing c:\program files (x86)\steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.bsp
1 second elapsed

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\hellzhero666\sourcesdk\bin\orangebox\bin\vrad.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\hellzhero666 eam fortress 2 f” -noextra “C:\Program Files (x86)\Steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2”

Valve Software - vrad.exe SSE (Apr 26 2012)

  Valve Radiosity Simulator     

8 threads
[Reading texlights from ‘lights.rad’]
[34 texlights parsed from ‘lights.rad’]

Loading c:\program files (x86)\steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.bsp
Setting up ray-trace acceleration structure… Done (0.09 seconds)
3014 faces
4276087 square feet [615756544.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
3014 patches before subdivision
180476 patches after subdivision
sun extent from map=0.000000
5 direct lights
BuildFacelights: 0…1…2…3…4…5…6…7…8…9…10 (11)
BuildVisLeafs: 0…1…2…3…4…5…6…7…8…9…10 (20)
transfers 17122990, max 829
transfer lists: 130.6 megs
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #1 added RGB(394989, 269192, 192998)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #2 added RGB(34847, 20894, 13861)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #3 added RGB(4281, 2148, 1316)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #4 added RGB(639, 314, 191)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #5 added RGB(115, 55, 32)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #6 added RGB(28, 14, 7)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (0)
Bounce #7 added RGB(8, 4, 2)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #8 added RGB(3, 1, 1)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #9 added RGB(1, 1, 0)
GatherLight: 0…1…2…3…4…5…6…7…8…9…10 (1)
Bounce #10 added RGB(0, 0, 0)
Build Patch/Sample Hash Table(s)…Done<0.0875 sec>
FinalLightFace: 0…1…2…3…4…5…6…7…8…9…10 (5)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0…1…2…3…4…5…6…7…8…9…10 (12)
Writing leaf ambient…done
Ready to Finish

Object names Objects/Maxobjs Memory / Maxmem Fullness


models 16/1024 768/49152 ( 1.6%)
brushes 220/8192 2640/98304 ( 2.7%)
brushsides 1352/65536 10816/524288 ( 2.1%)
planes 714/65536 14280/1310720 ( 1.1%)
vertexes 3971/65536 47652/786432 ( 6.1%)
nodes 1635/65536 52320/2097152 ( 2.5%)
texinfos 141/12288 10152/884736 ( 1.1%)
texdata 46/2048 1472/65536 ( 2.2%)
dispinfos 0/0 0/0 ( 0.0%)
disp_verts 0/0 0/0 ( 0.0%)
disp_tris 0/0 0/0 ( 0.0%)
disp_lmsamples 0/0 0/0 ( 0.0%)
faces 3014/65536 168784/3670016 ( 4.6%)
hdr faces 0/65536 0/3670016 ( 0.0%)
origfaces 814/65536 45584/3670016 ( 1.2%)
leaves 1652/65536 52864/2097152 ( 2.5%)
leaffaces 3380/65536 6760/131072 ( 5.2%)
leafbrushes 937/65536 1874/131072 ( 1.4%)
areas 2/256 16/2048 ( 0.8%)
surfedges 17048/512000 68192/2048000 ( 3.3%)
edges 9264/256000 37056/1024000 ( 3.6%)
LDR worldlights 5/8192 440/720896 ( 0.1%)
HDR worldlights 0/8192 0/720896 ( 0.0%)
leafwaterdata 1/32768 12/393216 ( 0.0%)
waterstrips 269/32768 2690/327680 ( 0.8%)
waterverts 0/65536 0/786432 ( 0.0%)
waterindices 3657/65536 7314/131072 ( 5.6%)
cubemapsamples 0/1024 0/16384 ( 0.0%)
overlays 0/512 0/180224 ( 0.0%)
LDR lightdata [variable] 11135300/0 ( 0.0%)
HDR lightdata [variable] 0/0 ( 0.0%)
visdata [variable] 162273/16777216 ( 1.0%)
entdata [variable] 95361/393216 (24.3%)
LDR ambient table 1652/65536 6608/262144 ( 2.5%)
HDR ambient table 1652/65536 6608/262144 ( 2.5%)
LDR leaf ambient 8492/65536 237776/1835008 (13.0%)
HDR leaf ambient 1652/65536 46256/1835008 ( 2.5%)
occluders 0/0 0/0 ( 0.0%)
occluder polygons 0/0 0/0 ( 0.0%)
occluder vert ind 0/0 0/0 ( 0.0%)
detail props [variable] 1/12 ( 8.3%)
static props [variable] 1/12 ( 8.3%)
pakfile [variable] 213472/0 ( 0.0%)
physics [variable] 80837/4194304 ( 1.9%)
physics terrain [variable] 2/1048576 ( 0.0%)

Level flags = 0

Total triangle count: 7791
Writing c:\program files (x86)\steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.bsp
57 seconds elapsed

** Executing…
** Command: Copy File
** Parameters: “C:\Program Files (x86)\Steam\steamapps\hellzhero666\sourcesdk_content f\mapsrc\HellzHero’s Map 2.bsp” “c:\program files (x86)\steam\steamapps\hellzhero666 eam fortress 2 f\maps\HellzHero’s Map 2.bsp”

** Executing…
** Command: c:\program files (x86)\steam\steam.exe
** Parameters: -applaunch 440 -game “c:\program files (x86)\steam\steamapps\hellzhero666 eam fortress 2 f” +map “HellzHero’s Map 2”

So how do i fix so when i run the map it will actually play on Team Fortress 2?

It seems you have a space in the map name, which the compiler actually doesn’t like. It also seems that the affects it too, so you’ll want to take that out.

shame

[sp]I think it’s because you’re running it from the “mapsrc” folder, but it’s looking for it in the TF maps folder.

Try moving it (the VMF) from “mapsrc” to your “tf/maps” folder. I’ve never liked doing stuff from the mapsrc folder as I like keeping everything all in one place.[/sp]

Edit:

Yeah I saw that too, but it also did it for the OB bin folder: “bin\o rangebox\bin”, so I dunno. Worth checking those out too.

Thats an issue with the forum. He does have spaces and special chars in the name though which will cause it not to run.

Ok so i removed the spaces and special characters and no longer does it come up with Map invalid. So now it tried to open the map but as soon as it opens it a message pops up saying:

ED_Alloc: No free edicts

Any solution?

Do you have a lot of entities in the map? Seems like the issue.

Holy shit, I missed that. I’m an idiot. Fact.