Cant see guns and gravity gun beam

this is hard to show or prove but if you need to ask anything or see let me know best way i can describe it is as follows:

Hello Ive been working on my new server for a few days and Ive ran into a big bug i cant seem to fix.

best way to describe it is when I change to a job I can scroll and see that I have the gun and I can shoot it but i dont see anything.

Also when I use the grav gun I dont see that either neither the beam for it too but I can still use it.

Another thing, I can fix it by killing myself but then my advance arresting battons turn into the vanilla ones.

I have tried removing adv arresting and re adding not sure if its the issue or not.
( still doesn’t work with it removed completely)

Please help!

all scripts have been purchased and not leaked!

I have the same issue with my murder server… weapons randomly disappearing and reappearing. Weapons are still usable while invisable, only way i can tell which weapon is out is by that numbered slot bar.