Can't see lamp or light colors?

I can’t see the colour that lamps OR lights give off. Wiremod or regular. I’ve defragged, verified cache, reinstalled. So I think it’s a video setting. I’ve maxed all settings and still nothing.
If someone who is able to see the lamp and light colours could please post a screenshot of their video settings, and I’ll give them a shot, that’d be awesome. I have tried updating to my newest GPU drivers and downgrading to since before it happened. No dice.

This is what I’m talking about, and if It’s a problem with my settings, there they are. http://imgur.com/a/ZC814

Put -dxlevel 95 in your startup parameters.

Fuckin’ saviour. Few things though.

Is there any way to prevent it from launching in such a small resolution?
The light tool still doesn’t give off light.

Wiremod light tool? And after you’ve started up once, delete the -dxlevel 95. You don’t need it anymore (that should solve the resolution issues).

Nope, the regular light on a rope tool. They don’t give off light, only the entity is self illuminated. The regular and wire lamps work, and the wire light is… No idea how to work it so we’ll forget about it.