Cant spawn anything in singleplayer

Hi

I tried looking for this on the forum but couldnt find any threads on this problem.
I cant seem to spawn anything using Q in singleplayer, it works fine when i create a multiplayer game.

Does anyone know what may be causing it? I tried to reinstall multiple times and im not using any addons.
I havent played Gmod in like a year and decided to reinstall it, so its a fresh install

Another wierd thing happening (only) in singleplayer is whenever i mouse-over categories in the Q menu it automaticly selects them.
Its hard to explain so i added a picture.
http://bildr.no/thumb/555179.jpeg
In the picture only the "Useful Construction Props"is selected (by defult when pressing Q?)
But i was moving my mouse over the other ones the game decided to select them.

I hope someone can help.

List your addons and PC specs (not sure how specs could effect it, but its usful)

Are you using a laptop atall?
If you are your elbow might be on the left click and your highlighting the categories otherwise yeah list addons and specs

I dont have any addons installed.

My specs:
GeForce GTX 275
3.07 GHz Quad Core
6GB DDR3 Ram
1TB 7500 RPM HDD
64-bit Vista

I also have the latest drivers and all that.

[editline]03:01PM[/editline]

Heh, i wish it was that easy =) im not on a laptop

Check mouse settings.