Can't use hammer after The Summer Hotfix

Hi everyone,

I’ve been working on a new map for a Gmod Cinema server (well, that doesn’t really matter, don’t?) and yesterday (day when I received The Summer Hotfix on my game) I was using the hammer. Well, when the download was successful, and applied, the hammer crashed (well, it didn’t really crash, it just closed, but by itself). Then, I tried to open it again, but this error appeared:

I know, that’s a classic error. But it hasn’t to appear! I’ve everything correct (I checked it!). I use the CS:S hammer for Garry’s Mod, and this is my actual configuration:

I’ve wroten it twice, but the hammer still shows that error. I don’t know what to do, I’ve using this program one month (or more) and I’ve never had this problem. Please, if you can, give me a solution. I need it to continue working on the map.

Thanks beforehand, and excuse me if I’ve wroten any misspell, because I don’t ussually speak English. See you in the comments below.

[editline]12th July 2014[/editline]

Oh c’mon give me help. I need it as soon as possible…

The fact you are getting that error using the non-GMod hammer means it had nothing to do with GMod.

But the Gmod Hammer can’t be used. For editing Gmod maps you’ve to configure the CS:S hammer for Gmod. That happened after the steampipe update, a couple of years ago.

I know. I’m saying this is a problem with the CS:S hammer; a hotfix for GMod wouldn’t break another hammer, especially when it’s missing a core element. Have you tried a different configuration or hammer to test the issue?

I don’t think it would help… In theory you’ve to use the CS:S hammer for Gmod (because both use Source MP) and I don’t know another game which uses Source MP. Also, I’ve tried to verify the CS:S cache, and it didn’t help.

[editline]12th July 2014[/editline]

Also I’ve to say that If I use the CS:S hammer for CS:S it works, but I can’t use it in that way because it don’t show most of the textures (and yes, I copied them in the materials folder of the CS:S)

That’s wrong. Any hammer, minus ones from unsupported Source engine versions and the old SDK, will work for GMod. The HL2, TF2, EP2, and SDK 2013 hammers all work for GMod.

Ok, I’ll try with the TF2 hammer. Thank you. I’ll tell later if it served or not.

[editline]12th July 2014[/editline]

I tried it with the TF2 hammer, but the error is the same. I used the same configuration as in the CS:S hammer… but the error persists.