Can't use wire gates

Ok so I updated my wiremod file with svn and now I can’t use none of gate tools, it says this everytime I try to spawn one
" wire\stools\sv_wirestools.lua:21: bad argument #1 to ‘IsValidModel’ (string expected, got boolean)"
Can someone please explain to me why I have this problem ?

Did you remove all old Wiremod things before downloading the SVN?

I get that too.
And yes, i removed everything before svn update.