Cave area displacement problem

Hey, Im working on a cave type map, and Im trying to get that uneven ground “cave-ee” look. To do this, since it’s a big cave, I made all of the brushes making up the walls into displacements, then used the noise function, which did do the job nicely, but all the edges became unaligned. So, what I’m asking is, is there a way to make the displacements/brushes actually become one brush or displacement, or a way to align the edges of the displacements after I add the noise? Thanks in advance.

Select the displacements you want to be fit together, then click “Sew” in the displacement menu.

Have you ever tried doing that after adding noise? I already did, and had to Ctrl+Alt+Del hammer because I got too many error messages to close.

[editline]10:06PM[/editline]

I gotta get off 4 the night, responses still welcome.

I know this is old but I could still use help.

I recommend setting it up for subdivide (only if you know how) then subdividing it. Then manually mush up your cave, it makes it look better, ill post screens later.