"CD Key Authentication Invalid for Internet Servers" When Hosting GMOD Server Locally

Ever since I stopped using a VPS for development, I’ve wanted to host a server using SRCDS locally to develop. Unfortunately, I get the error message in the title whenever I try to join a server on my own computer. I’ve scoured Google for answers and couldn’t seem to find anything that worked. Yes, I do own Garry’s Mod and I can join every other server without this happening. For now, I’m stuck using the “Start New Game” option.

Did you anonymously log in to steamCMD and download the Gmod dedicated server and not use your steam account?

Whoops, yes. Reinstalling.

Edit:

Now I get the following error: “ERROR! Failed to install app '4020 (No Subscription).” As I said before, I did buy Garry’s Mod, so that can’t be the problem. Any idea what is causing this?

If you logged in Anonymously then it would install without any errors about the no subscription. Unless you logged into your steam account

You should try this https://github.com/DioJoestar/SteamCMD-GUI


Loading Steam API...OK.

Steam>login anonymous

Connecting anonymously to Steam Public...Logged in OK
Waiting for license info...OK

Steam>app_update 4020
 Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
 Update state (0x3) reconfiguring, progress: 0.00 (0 / 0)
 Update state (0x61) downloading, progress: 0.19 (7148657 / 3761002234)
 Update state (0x61) downloading, progress: 0.59 (22376601 / 3761002234)
 Update state (0x61) downloading, progress: 0.61 (22824416 / 3761002234)

this is literally all you need to do and it will start and launch just fine

That’s exactly what I did when I installed it, both on my computer and the VPS I had. I have no trouble installing it, and I am well aware of how to do it anonymously. I only got the CD Key error message when I tried to join it on my computer.

He just told me to try it using a Steam account, so I did. I already tried logging in anonymously which gave me the error message in the title whenever I would join. I know how to use the command line version so I see little use for a GUI. Might as well try to reinstall for the 5th time.

Maybe you guys need clarification: I have installed the server already, with no hiccups. I can not join the server because of that error in the title.

EDIT: Well, it seems like the 6th time is the charm. Solved.